0

I am seeing this on a Lenovo Flex 5-14. Ubuntu is freezing with message saying the filesystem is not writeable.

I tried fsck and smartctl. Neither showed any errors. I have dual boot and Windows 10 seem to be working fine perfectly.

This is the error that I am getting. enter image description here

7
  • Tried remounting? sudo mount -o remount,rw / May 9 at 23:03
  • 1
    The error happened earlier. Why did the disk where /var/log/*.log are written to, get mounted Read Only?
    – waltinator
    May 9 at 23:15
  • If errors are detected on a file-system, a RW mount will flip to RO (read-only as per your messages) so as to prevent data loss. You should check your logs to see the cause (it maybe a once-off due to power-surge etc esp. if you don't have good line filters & other heavy devices near by that are turned on/off during sessions) then boot a live system and check for errors (fsck)... Occurring only rarely is not a problem, but regular occurrences are a symptom of a problem that should not be ignored (and the flipping to RO is a symptom & not the cause!)
    – guiverc
    May 10 at 1:00
  • Once the error starts coming, nothing works. The system freezes completely. No, terminal, no Ctrl + Alt + F1. Only thing that works from that point is a hard reboot.
    – anoopjohn
    May 10 at 20:55
  • Once the fs has flipped RO you need to limit yourself to commands that read output only, Ctrl+Alt+F1 is by default GUI which will be harder to use (RO) than a text terminal... SysRq commands to kernel will still function so you can tell your system to cleanly shutdown (unless you've suffered panic which is a different situation you've not mentioned) but I'd usually opt to look for clues as some detail is lost on reboot (eg. dmesg but you'll have to limit yourself to using it without piping etc that needs write)
    – guiverc
    May 10 at 23:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.