16

After I've upgraded to 12.04, I cannot unbind Ctrl+Alt+T from launching gnome-terminal anymore. I've tried disabling it completely and assigning it to another shortcut in [System Settings -> Keyboard] - nothing helps, Ctrl+Alt+T still launches terminal. Any ideas how to get rid of it?

BTW, this breaks Ctrl+Alt+T in gnome-terminal itself, which is supposed to open new tab, but instead fires up new window.

Also, on a side-topic. This "shortcut hell" has been a problem since introduction of unity. Shortcuts are now configured in two different places. Every release they add/delete/change shortcuts - so I basically have to go and figure out how to disable/remap the ones that I use in my IDE. Now, it seems, you can't disable them completely (e.g. Alt + `) and have to override with another shortcut to unbind the default one.

What I'm really trying to ask here - does anyone know if there is a launchpad bug to fix this kind of behaviour, so I can vote \ track it? Or should I just create new one and see what happens?

3
  • 3
    Minor point, but to open a new tab in gnome-terminal you need to do Ctrl-Shift-T, not Ctrl-Alt-T. May 8, 2012 at 11:58
  • Also, I just tried and for me I can make "launch gnome-terminal" be bound to another key, and then Ctrl-Alt-T does nothing. I have also recently upgraded to 12.04 from 11.10. Finally, where is the 2nd place for configuring shortcuts - I'm only aware of the one place. May 8, 2012 at 11:59
  • About Ctrl-Alt-T and Ctrl-Shift-T - yes, you're right, my mistake. Second place is compiz config - there are some keybindings you can configure in "Gnome Compatibility", "General Options" and "Unity Plugin".
    – alepar
    May 9, 2012 at 8:01

4 Answers 4

10

I found this to work for me to disable to keyboard shortcut for running a terminal:

  • Press the super key to start a search
  • Search for Configuration Editor and select that application
  • Drill down the following: apps >> metacity >> global_keybindings
  • Scroll down until you see run_command_terminal
  • You can remove or type in the word disabled to the right of run_command_terminal
  • Press the red 'X' at the top of the Configuration Editor application
  • Verify the save by going into: System Settings >> Keyboard >> Shortcuts

Pictures of what it should look like in both the Configuration Editor and System Settings area. Hope this helps!

enter image description here

enter image description here

1
  • 1
    While this looks like a solution, and disabled keybinding in gnome keyboard settings, still, it looks like something else is intercepting Cttrl-Alt-T and launching Terminal for me. I've tried searching for all values containing <Control><Alt>T in Configuration Editor and disabling them - there was a bunch related to gnome compatibility compiz plugin. Unfortunately, that didn't help. This has prob something to do with my 11.10->12.04 upgrade - I was upgrading when it was in alpha stage. Something went wrong, and I had to boot to live cd and manually recover. Any ideas what else could be wrong?
    – alepar
    May 9, 2012 at 8:09
8

On current Ubuntu metacity is no longer the default window manager, so the accepted solution no longer works. Instead there's a different setting that you can change. Set the key combination to an empty array.

In a terminal:

gsettings set org.gnome.settings-daemon.plugins.media-keys terminal '[]'

To undo the change again

gsettings reset org.gnome.settings-daemon.plugins.media-keys terminal 

In case this changes again, I found this by looking for all settings that mention "terminal"

gsettings list-recursively | grep terminal

I had this problem because it interferes with an Emacs keybinding to transpose sexps.

2
  • 1
    as of the date of this comment this answer works, the accepted one has been out of date for a long time.
    – user17723
    Jul 15, 2018 at 15:22
  • > I had this problem because it interferes with an Emacs keybinding to transpose sexps. --- Same! Glad to have found this answer. This worked for me today, even as 2020 approaches. Thanks!
    – Harold
    Dec 22, 2019 at 20:15
1

Alepar: Look into "Custom Shortcuts" in Settings/Keyboard (seen in the ruffEdgz' answer). I had the same problem; I could not remove the custom shortcut, but it was possible to rebind it so that it did not interfere with the IDE.

0

Also, for anyone looking for a more updated answer, or an answer for UbuntuMATE, Go to Config Editor, and look for the following:

org > mate > applications > terminal

And change exec to whatever application you like and remove exec-arg, this changed the bind for me because I used terminator, I'm not sure what else that changes.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .