1

uname -a Linux username 5.8.0-50-generic #56~20.04.1-Ubuntu SMP Mon Apr 12 21:46:35 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux

I read all the tutorials and forums.

add "/module/bluetooth/parameters/disable_ertm=1" to /etc/sysfs.conf file

I initially it pairs (shows as connected) but the controller keeps blinking and then disconnect ...

I just bought the xbox controller (X/S 2020 forth generation model) There is a lot of info out there (mainly for older version, distributions and models)...

Tried with terminal (using bluez, looking for error meaningful msgs):

bt-device -l

Added devices:
Xbox Wireless Controller (44:16:22:D1:F1:57)
bt-device -c 44:16:22:D1:F1:57
Connecting to: 44:16:22:D1:F1:57
Error: GDBus.Error:org.bluez.Error.ConnectionAttemptFailed: Page Timeout

dmesg | grep Bluetooth

(I get repetitions of these lines)

hci0: advertising data len corrected 20 -> 0
hci0: link tx timeout
hci0: unexpected SMP command 0x0a from 44:16:22:d1:f1:57

If it make sense to you, do you have any idea where I should be looking? thanks for your help...

1
0

I'm having the exact same problem described above and have tried the same "fixes". I'm really sorry not to be able to help.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.