2

Whenever I open a PDF document in Telegram, it opens in Xournal++. But I want it to open with Okular, which I have set as the default PDF reader.

PDF documents in Dolphin do open with Okular. How to make PDF files in Telegram open with Okular?

I am using Kubuntu 20.04, and the binary executable for Telegram.

KDE settings does not have any entry for default PDF application. Dolphin has settings to set a default PDF application, but that probably only applies to Dolphin.

enter image description here

2 Answers 2

1

I had the same problem. After read this link I've tried to change the order of applications in kde PDF file properties then saved. After that I've restored Okular as primary handler and saved. Finally I've quit and restart Telegram and it started to open PDF with Okular.

2
  • Do I change the order of applications in "Open With" in Dolphin? Nov 15, 2021 at 20:17
  • Yes, it's what I did.
    – dharman
    Nov 16, 2021 at 11:43
1

Try setting the default application back to Xournal++ and then switch back to okular. This apparently solves the problem in some cases.

1
  • KDE settings does not have any entry for default PDF application. May 10, 2021 at 8:07

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .