I need help.

I have installed Ubuntu 20.04 on my Toshiba CB35-B3340, no dual booting. I have no sound from my speakers or headphones.

When I go to sound settings, the only output device shown is HDMI/Display port.

When I run alsamixer, I only see S/PDEF, there is no master or headphones, etc.

I have tried many of the suggestions posted without success. I am not too experienced, but will to try. Any suggestions are appreciated.

1 Answer 1

  1. Use aplay -l to see your playback hardware devices.

  2. You should see your device sound card, according to your notebook, look for the one that looks like (Make sure that it refers to analog output):

    card 0: PCH [HDA Intel PCH], device 0: ALC887-VD Analog [ALC887-VD Analog]
  3. Make a new configuration file: sudo gedit /etc/asound.conf

  4. Put the following and save the file:

    defaults.pcm.card 0 # Replace with your card number
    defaults.pcm.device 0 # Replace with your device number
  5. Reboot your computer.

  • Here's what I see, the card number is 0, the device number is 3, correct?
    – jsaff1902
    May 7, 2021 at 17:19
  • john@john-Swanky:~$ aplay -l **** List of PLAYBACK Hardware Devices **** card 0: PCH [HDA Intel PCH], device 3: Generic Digital [Generic Digital] Subdevices: 1/1 Subdevice #0: subdevice #0 card 1: chtmax98090 [chtmax98090], device 0: Audio () [] Subdevices: 1/1 Subdevice #0: subdevice #0 card 1: chtmax98090 [chtmax98090], device 1: Deep-Buffer Audio () [] Subdevices: 1/1 Subdevice #0: subdevice #0
    – jsaff1902
    May 7, 2021 at 17:19
  • Yes, it's correct, that's the sound card.
    – user1208493
    May 7, 2021 at 17:21
  • Ok, made the file, saved and rebooted. Now when I go to the sound settings, I see that the output device options are now multichannel and analog output-built in audio. When I test, there is no sound. Alsamixer for card 0 still only shows S/PDIF, if I choose card 1 I do see master, headphones, etc. is that important?
    – jsaff1902
    May 7, 2021 at 17:47
  • I'm not sure, but perhaps it's because the sound output it's related with the card: 1, device: 0. Try to change the /etc/asound.conf with card number to: 1 and device number to: 0, save and reboot.
    – user1208493
    May 7, 2021 at 18:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.