I'm using an Ubuntu host to run a Windows 7 guest OS in virtualbox. Until I upgraded to 12.04, virtualbox started and booted the guest OS normally and everything was good.

After I upgraded to 12.04, whenever I tried to boot the guest OS, at some point in the boot process my computer would black screen, crashing both the guest and the host.

Are there any ways to figure out exactly what is causing the crash? Is there a solution that will allow me to continue using virtualbox without crashing the host OS?

I'm using kernel version 3.2.0-24 and virtualbox version 4.1.12.

  • What version of Virtual Box are you using?
    – Takkat
    May 8 '12 at 7:50
  • I'm using virtualbox 4.1.12. I edited the question to add this.
    – tjlevine
    May 8 '12 at 8:03

Can you update to the new version 4.1.14?

To do this, add a new source:

sudo gedit /etc/apt/sources.list.d/virtualbox.list

And copy the following line into gedit, and save

deb http://download.virtualbox.org/virtualbox/debian precise contrib

Then add the signed key:

wget -q http://download.virtualbox.org/virtualbox/debian/oracle_vbox.asc -O- | sudo apt-key add -

And then do a sudo apt-get update && sudo apt-get dist-upgrade

I think this will solve your problem, because we use the latest version, and we have no problems.


We can not reproduce crashes of Virtual Box 4.1.12 in 12.04. Here are some suggestions of what you can try:


Booting with an older kernel, version 3.0.0-17 seems to fix the problem.

Using this kernel version I can boot the guest OS in virtualbox and use it normally.

The cause of this problem seems to be a regression in the kernel.

  • This isn't a perfect solution for me however, as I'd still like to be able to use the new kernel version. I'll try updating to virtualbox 4.1.14 and see if that solves the problem with the new kernel.
    – tjlevine
    May 8 '12 at 18:49

For Virtual Box 4.1.14 from the virtualbox.org repository try:

sudo apt-get install linux-headers-generic linux-headers-generic-pae
sudo /etc/init.d/vboxdrv setup

Good luck!

For Ubuntu 12.04's virtualbox 4.1.12 installed from the default repository, I could not find /etc/init.d/vboxdrv


Edit: reinstalling virtualbox seemed to work at first but did not really solve the problem. However, the true problem was found and fixed upstream, see here: https://www.virtualbox.org/ticket/10528

Such bugreport above also lists a workaround to be used until the fixed packages are available i.e.:

A workaround is to add nmi_watchdog=0 nowatchdog to the command line of the host kernel

(previous answer, now invalid)

I had the same problem when attempting to run a 64bit Windows 7 guest OS in virtualbox and solved the issue by simply uninstalling and reinstalling virtualbox, as recommended here: VirtualBox doesn't load after 12.04 upgrade. It apparently recreated some kernel modules which were missing after the first installation.

sudo apt-get remove virtualbox
sudo apt-get install virtualbox

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.