0

Up until a few weeks ago, I would receive messages letting me know about updates whenever I logged in via SSH. I would also get the same message(s) running

/usr/lib/update-notifier/apt-check --human-readable

Now I’m not getting anything. Did something change recently?

And before I could run the following as su to update. Is this not correct?

apt-get update && apt-get upgrade -y && apt-get dist-upgrade -y && apt autoremove -y

3
  • I just tried and couldn't reproduce your problem. I get the message as I ssh to my system. It said "2 updates can be installed immediately" . Then I ran sudo apt update followed by '/usr/lib/update-notifier/apt-check --human-readable', and got "39 updates can be installed immediately.". Your set of commands to update, upgrade, and autoremove should work. You don't need both apt-get upgrade and apt-get dist-upgrade. Only the second one is sufficient. I use something similar: sudo apt update && sudo apt -y upgrade && sudo apt -y --purge autoremove.
    – user68186
    May 6 at 15:58
  • Yes that's normal. if there it nothing to be installed or upgraded.. The ubuntu motd system if pretty specified these days.. It includes settings news from motd.ubuntu.com and also /var/run/motd.dyanmic. May 6 at 16:11
  • And what generates the /var/run/motd.dyanmic file is to be found in /etc/update-motd.d May 6 at 16:13
1

The answer is that because you've done a update and an upgrade there is nothing to update. the motd message is generated by the update-motd tool. You'll find the scripts used to generate them in /etc/update-motd.d/ these are normally triggered by PAM (on login).

You can even run them from the command line to see what they would output.

http://manpages.ubuntu.com/manpages/bionic/man5/update-motd.5.html

5
  • I thought that as well, but I haven’t been getting any update messages for several weeks now. May 6 at 19:46
  • Perhaps its because of the Ubuntu 21.04 release and all the support efforts are going to its packages now? The last LTS (Long Term Support) release is 20.04 and every six months they drop a edge release.. May 7 at 7:44
  • Not that there are any updates for 21.04 either ;maybe they are taking a break ;-) root@ys:/etc/update-motd.d# uname -a Linux ys 5.11.0-1007-raspi #7-Ubuntu SMP PREEMPT Wed Apr 14 22:08:05 UTC 2021 aarch64 aarch64 aarch64 GNU/Linux root@ys:/etc/update-motd.d# /etc/update-motd.d/90-updates-available May 7 at 7:45
  • I don't think its something we have broken its just that there are no updates to be displayed.. I think you can stand down... ;-) May 7 at 7:50
  • you’re correct. I finally got some updates. May 16 at 2:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.