On recently upgrading to 12.04, I find that the middle click with my logictec marble mouse doesn't work any more (formally achieved by clicking both buttons). Anoying since I can't do a middle-click paste.

Can anyone think of an easy solution? Or should I file a bug?

(theres's already a launchpad question on this, and here's the oldish ubuntu page for configuring a marble mouse.


I found the answer here and here. You need to run the following command:

gsettings set org.gnome.settings-daemon.peripherals.mouse middle-button-enabled true

You only need to do this once - Gnome remebers the setting for your next logon - though you need to do it for each user. If someone knows a way around this, feel free to edit this answer (:

It seems Gnome sets this to 'false' by default, and does so after xorg does it's settings (so it overrides xorg settings in xorg.conf or ...-evdev.conf etc..)

The setting can also be changed with the dconf-editor in the dconf-tools package (thanks Walt). Go to org::gnome::settings-daemon::peripherals::mouse and tick 'middle-button-enabled'.

| improve this answer | |
  • No such schema 'org.gnome.settings-daemon.peripherals.mouse'. – Dave Jarvis Mar 24 '13 at 20:04
  • @DaveJarvis can you provide more info? The above commands all still work for me.. – drevicko Mar 24 '13 at 23:12
  • I found a work-around: askubuntu.com/a/272009/64957 ... Don't know why gsettings couldn't find the schema. – Dave Jarvis Mar 24 '13 at 23:34
  • @Dave I think I see the difference now: It seems Xubuntu 12.04 LTS running Xfce does not override those X settings, so changing the xorg files works. Looks like the mouse settings have been removed from Xfce/Xubuntu (hence the 'No such schema' error). – drevicko Mar 24 '13 at 23:55
  • I have the same problem with Ubuntu 16.04 GNOME 3. I tried gsettings set org.gnome.settings-daemon.peripherals.mouse middle-button-enabled true but it says No such key 'middle-button-enabled'. Any thoughts to fix it. Thanks – MYaseen208 Aug 31 '16 at 22:26

I am experiencing the same problem after updating from 10.04. I have applied the settings to /usr/share/X11/xorg.conf.d/10-evdev.conf as suggested in https://wiki.archlinux.org/index.php/Logitech_Marble_Mouse and this gives the required scrolling using the trackball, but the two-large-button middle-click merely gives a right-click effect.

I have appended the following settings ing 10-evdev.conf:

Section "InputClass"
        Identifier  "Marble Mouse"
        MatchProduct "Logitech USB Trackball"
        MatchIsPointer "on"
        MatchDevicePath "/dev/input/event*"
        Driver "evdev"
        Option "ButtonMapping" "1 8 3 4 5 6 7 2 2"
        Option "EmulateWheel" "true"
        Option "EmulateWheelButton" "8"
        Option "ZAxisMapping" "4 5"
        Option "XAxisMapping" "6 7"
        Option "Emulate3Buttons" "true"

This maps the middle button click to either of the small buttons (8 & 9) and allows the holding down of button 8 (small left button) for the track-ball scrolling. While not ideal (I also prefer the two-large-button==middle-click) this might be a good enough compromise (I think it will be for me at least).

I would also suggest that the loss of Emulate3Buttons is a bug and should be reported. This setting worked fine with this mouse on 10.04.

| improve this answer | |
  • Thanks theabro. Doesn't actually answer the question, but its good to have this info here (: – drevicko May 13 '12 at 2:41
  • That's great drevicko - that now gives the middle-click working on my system. The line Option "Emulate3Buttons" "false" will need to be changed to Option "Emulate3Buttons" "true" for this as well I think. – theabro May 14 '12 at 11:29
  • yep, it will (: I'll change it in the question now.. – drevicko May 14 '12 at 23:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.