1

Today I was trying to install steam. Multiverse repository is available from the beginning. But using command sudo apt install steam what I get is

sudo apt-get install steam
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package steam is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'steam' has no installation candidate

I've been trying to install steam-installer, but it requires steam so it's not working.

I tried with sudo dpkg --add-architecture i386 but also with no luck.

Of course I used sudo apt update but it also didn't help.

What should I do? Very similar problems appeared when I tried to install wine and I also couldn't do it.

Here's what I get from grep ^deb -r /etc/apt/ --include=*.list:

/etc/apt/sources.list.d/phoerious-ubuntu-keepassxc-focal.list:deb http://ppa.launchpad.net/phoerious/keepassxc/ubuntu focal main
/etc/apt/sources.list.d/slack.list:deb https://packagecloud.io/slacktechnologies/slack/debian/ jessie main
/etc/apt/sources.list:deb http://archive.ubuntu.com/ubuntu focal main universe restricted multiverse
/etc/apt/sources.list:deb http://security.ubuntu.com/ubuntu/ focal-security universe multiverse restricted main
/etc/apt/sources.list:deb http://archive.ubuntu.com/ubuntu focal-updates universe multiverse restricted main
/etc/apt/sources.list:deb http://archive.ubuntu.com/ubuntu focal-backports universe multiverse restricted main
11
  • Please add sudp apt update to your question?
    – nobody
    May 6, 2021 at 7:51
  • @N0rbert Well, I did recreate sources.list and nothing has changed unfortunately
    – theMatt
    May 6, 2021 at 8:21
  • Are you running x86_64? Also please run sudo apt-get update and add grep ^deb -r /etc/apt/ --include=*.list to the question or pastebin.
    – N0rbert
    May 6, 2021 at 8:21
  • @nobody Of course I did sudo apt update but it didnt help
    – theMatt
    May 6, 2021 at 8:22
  • @N0rbert edited my question with result of your command
    – theMatt
    May 6, 2021 at 8:41

1 Answer 1

2

During chat session we have discovered the following moments:

  1. For some reason sudo dpkg --add-architecture i386 did not worked for first time. So we ran it multiple times.

  2. For reproducible results we removed local software lists by sudo rm /var/lib/apt/lists/* and then run sudo apt-get update again.

  3. We discovered that the system had two different versions of libc6 packages for amd64 (2.31-0ubuntu9.2 from official repository) and i386 (2.31-0ubuntu9.3 from some local source), so we installed correct versions by

    sudo apt-get install libc6=2.31-0ubuntu9.2 libc6:i386=2.31-0ubuntu9.2 
    
  4. Finally we installed Steam by

    sudo apt-get install aptitude
    sudo aptitude install steam:i386 
    

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .