0

I am using Asus Vivobook 15 X510U with Intel i7 - 8550U, 8 GB RAM, Nvidia MX 150. After a recent update, my laptop is failing to suspend when the lid closes. When I open the lid again, it shows only the Asus logo and I have to hard reboot the system again

POP!_OS : 20.10 Kernel : 5.11.0-7614-generic

0
0

Try looking on power management in the system settings. There should be a section where it says when laptop lid closed... and then you have the various options. Have you tried this Suspend on lid close doesn't work 16.04 ?

4
  • Wow! Thanks a lot. That script solved the issue! Thanks a lot again:) – Marivishnu May 6 at 9:06
  • Hi, the solution you gave worked. But after suspending for 30 mins, my laptop wakes up with a blank screen. Do you have any fix for that? @enrico223 – Marivishnu May 6 at 12:09
  • Unfortunately I don't, sorry... – enrico223 May 6 at 12:33
  • Don't be sorry! I found out about the black screen issue. It turns out to be NVIDIA driver issue. I reinstalled and it's now fine. Thanks for your reply. :) – Marivishnu May 6 at 14:30

Not the answer you're looking for? Browse other questions tagged or ask your own question.