0

Steam doesn’t load anymore. To see what was the problem, I opened a terminal and typed steam. I got this:

Loaded SDL version 2.0.15-6484190
Gtk-Message: 18:06:27.386: Failed to load module "overlay-scrollbar"
Gtk-Message: 18:06:27.388: Failed to load module "appmenu-gtk-module"

(steam:10167): Gtk-WARNING **: 18:06:27.393: Impossible de trouver le moteur de thème dans module_path : « pixmap »
(This message is repeated many times.)

(steam:10167): Gtk-WARNING **: 18:06:27.400: Impossible de trouver le moteur de thème dans module_path : « adwaita »
Gtk-Message: 18:06:27.401: Failed to load module "canberra-gtk-module"
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast
Steam: An X Error occurred
X Error of failed request:  BadMatch (invalid parameter attributes)
Major opcode of failed request:  151
Serial number of failed request:  50
xerror_handler: X failed, continuing
assert_20210505180626_1.dmp[10254]: Uploading dump (out-of-process)
/tmp/dumps/assert_20210505180626_1.dmp
/home/guillaume/.local/share/Steam/steam.sh : ligne 771 : 10167 Erreur de segmentation  $STEAM_DEBUGGER "$STEAMROOT/$STEAMEXEPATH" "$@"

I tried to (re)install the missing modules with:

sudo apt install --reinstall canberra-gtk-module
sudo apt install --reinstall appmenu-gtk2-module appmenu-gtk3-module
sudo apt install --reinstall overlay-scrollbar

and some variations of these but it didn’t change a thing. I also downloaded from the official site and reinstalled steam_latest.deb, but nothing changed.

I totaly uninstalled Steam (https://askubuntu.com/a/217875/269948) and reinstalled it with steam_latest.deb, but to no avail.

Could someone tell me what I must do to make steam work?

6
  • 1
    Please edit the question and add Ubuntu release/version and also describe to the best of your recollection what you did prior to noticing the issue with Steam. – ChanganAuto May 5 at 18:22
  • @ChanganAuto For the Ubuntu version, I already put the tag 20.10. I think I may have uninstall a few Gnome utilities from the Ubuntu “Discover” app, but I don’t remember which one. – guillaume8375 May 5 at 19:22
  • You can refer to the logs in /var/log/apt/history.log to find out what you deleted. – Organic Marble May 5 at 19:56
  • As above. And you can try to reinstall the Ubuntu desktop: sudo apt install --reinstall ubuntu-desktop – ChanganAuto May 5 at 19:58
  • @ChanganAuto sudo apt install --reinstall ubuntu-desktop didn’t work. – guillaume8375 May 6 at 15:45
0

You can try removing pinned_libs_32 and pinned_libs_64 folders from steam folder.

If you installed the .deb package from the official site, you can do:

cd ~/.local/share/Steam/ubuntu12_32/steam-runtime
mv pinned_libs_32/ bak-pinned_libs_32
mv pinned_libs_64/ bak-pinned_libs_64

Now try to run steam

6
  • I’ll try that once at home. – guillaume8375 May 6 at 9:55
  • It didn’t work. I got a message about pins “rebuilding” after typing steam, but the app didn’t launch. – guillaume8375 May 6 at 15:35
  • I think that the other answer is in the right path. Try to reinstall mesa-utils and reboot your computer. Here is some additional info: github.com/ValveSoftware/steam-for-linux/issues/4909 – user1208493 May 6 at 17:00
  • I tried sudo apt install mesa-utils and sudo apt install mesa-utils:i386 and both didn’t work. apt did not find mesa-utils:i386. – guillaume8375 May 6 at 20:51
  • 1
    Sorry, I don't know what could be the fix for mesa-utils didn't found. But you can try installing Steam via Flatpak. I read that many users solved a similar issue doing that, but for others didn't work and they received the same error. You could give it a try anyway. – user1208493 May 6 at 21:23
0

The error is the following. Steam was not able to detect a 3D accelerated GPU driver and did not continue.

libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast

Run glxinfo and glxgears to verify that you have enabled supported drivers for GPU hardware acceleration.

2
  • I’ll do that once I’m back home. – guillaume8375 May 6 at 9:52
  • glxgears worked, and glxinfo gave me this: ``` name of display: :1 direct rendering: Yes server glx vendor string: NVIDIA Corporation server glx version string: 1.4 server glx extensions: GLX_ARB_context_flush_control, GLX_ARB_create_context, ... GLX_SGI_video_sync client glx vendor string: NVIDIA Corporation client glx extensions: GLX_ARB_context_flush_control, GLX_ARB_create_context, ... GLX_SGI_video_sync GLX extensions: GLX_ARB_context_flush_control, GLX_ARB_create_context, ... GLX_SGI_video_sync ... ``` – guillaume8375 May 6 at 15:44
0

I am assuming you recently upgraded Nvidia driver to 465 from the ppa. It is missing the 32bit libraries and has now been taken down, so revert to 460 if using Nvidia from ppa or wait a while for a re-release.

3
  • How could I revert to 460? – guillaume8375 May 6 at 15:56
  • sudo apt-get install nvidia-driver-460 – DCow May 6 at 18:31
  • It didn’t work. – guillaume8375 May 6 at 20:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.