I am running 12.04 on a Core 2 Duo T8100 at 2.10ghz with Intel GM965/GL960 integrated mobile graphics with shared memory. I have 3gigs of ram but it normally stays below 1 gig.

Super Key hangs and programs hang when few programs are open. With many programs and tabs open, windows fade (almost) properly and nothing seems to hang, but typing and mouse gestures still lag, though not quite as bad. Ram usage increases to approx 2 gig, still no swap. Boots rather slowly and crypto swap hangs, but I kind of expect that with a 5400RPM drive, should I not?

I was assuming this is a graphics related problem so I ran unity_support and all questions were answered with a 'yes.' I also installed the updated drivers from the Ubuntu X team PPA (after confirming its validity, of course). I checked the minimum requirements and all are met a bit better than stated (I think). Also, 2D has the same issues (so not a compositing issue, right?). I also installed mesa-utils and upgraded, updated and restarted. No help, but instead of "graphics unknown" in system monitor, there simply is no field for graphics. libgl gives a "no such file or directory" error when searching for the driver, but I am not sure how to read that file, posted below. Sorry to be so long, just trying to provide all the info I can. Also, this problems seems to go away after the PC is left on for some time (hours or overnight) only to reappear on restart.

lspci is http://paste.ubuntu.com/975031/ Libgl verbose is http://paste.ubuntu.com/975013/ latest xorg log is http://paste.ubuntu.com/975020/ var/log/syslog from this session is http://paste.ubuntu.com/975036/

Edit: This is a clean install and I did not have this problem upon intitial install or with live usb. Already turned off all sync programs. Also have preload installed.

Possibly related to bug here. If you can confirm that this is related to said bug, please feel free to close the question with the appropriate comment. If you have found this post and you have intel 965gm please follow link and click "this also affects me"

  • 2
    Do me this sounds like a heat issue, laptop or desktop? Try giving it a good cleaning and see if that helps at all.
    – TheXed
    May 8, 2012 at 18:17
  • Laptop, I took it apart and cleaned prior to install, but that doesn't mean everything is communicating properly. Truly, a heat issue was something I had not thought of. I will check when I get home what temp it is running and repost. Thanks for your reply. May 8, 2012 at 19:05
  • Completely forgot about overheating issues with core 2 duo and above! Added "pcie_aspm=force" to GRUB menu and updated grub, "grub-update" No problems after restart so far! Thanks "TheX" you jogged my memory! I was convinced it was a graphics problem until you mentioned overheating...then I remembered I had done SOMETHING with another PC, I just couldn't remember what...till now! May 9, 2012 at 19:19
  • Glad I could help.
    – TheXed
    May 10, 2012 at 2:56

2 Answers 2


In my case adding pcie_aspm=force to the Grub config didn't help. It seems that the poor graphic performance is related to this bug: Poor performance on Intel® 965GM x86/MMX/SSE2. If anyone with Intel 965GM experiences the same problems please go and vote for it (see how to vote and make sure you're logged in), hopefully it will get fixed sooner.

  • Agreed, seems to be multiple issues on precise related to Graphics. May 15, 2012 at 1:11

To summarize with some intructions, if you are experiencing these issues (with a Core 2) you may want to try...

gksudo gedit /etc/grub/default

find the line that reads similar to


and edit it to read

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash pcie_aspm=force"

Core 'i' series may need additional tweaking, see here for details.

Phoronix has an article about a 'proper solution' AKA a patch, but that is beyond my level of expertise. Anyway, this will do well enough for me until the kernel gets that support!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .