0

I installed nvidia drivers (driver 460). For that I did the installation via tty as nvidia want. To do that, I did

 systemctl disable lightdm.service

because a

systemctl stop lightdm.service 

didn't work

Now I have the nvidia driver installed (I can see that with nvidia-smi). But I can't rerun lightdm.

I tried differents methods:

systemctl enable lightdm.service
dpkg-reconfigure lightdm
apt install --reinstall lightdm
update-alternative --config display-manager.service
systemctl restart lightdm
systemctl enable lightdm.service

With this last command, The screen switch from tty to black screen (it's the same if I reboot without doing anything)

and when I do

 systemctl enable lightdm.service

I have the following message:

 The unit files have no installation config (WantedBy, RequiredBy, Also, Alias
settings in the [Install] section, and DefaultInstance for template units).
This means they are not meant to be enabled using systemctl.
Possible reasons for having this kind of units are:
1) A unit may be statically enabled by being symlinked from another unit's
  .wants/ or .requires/ directory.
2) A unit's purpose may be to act as a helper for some other unit which has
  a requirement dependency on it.
 3) A unit may be started when needed via activation (socket, path, timer,
  D-Bus, udev, scripted systemctl call, ...).
4) In case of template units, the unit is meant to be enabled with some
  instance name specified.

I haven't other idea to solve my problem now

1
  • Very strange. What is the contents of lightdm.service ? Copy the output of a cat /usr/lib/systemd/system/lightdm.service into your question. I guess you are using Xubuntu (which you did not mention) – kanehekili May 8 at 23:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.