I've just installed Ubuntu 12.04 (64-bit) on a brand new Dell Latitude e6420, and I'm having a few problems. This laptop has an Optimus (?) setup - i.e. integrated gfx and an Nvidia Quadro NVS 4200M.

  1. First problem - I ran setup, etc, and discovered that I can only run unity2d - If I try and login with unity3d, it just defaults to 2d. This is with nvidia-current installed (302.07). Note also that I can't run nvidia-settings ("You do not appear to be using the NVIDIA X driver."), and there is no additional drivers found ("No proprietary drivers are in use on this system").

  2. I tried to troubleshoot this, and removed nvidia, leaving (I guess) just Nouveau drivers - In that case, unity3d did work, but I was stuck with the open source Nouveau drivers powering the integrated graphics.

So, obviously, I want to run unity3d, and be using the more powerful Nvidia graphics card.

I've tried a bit of tinkering around, but I'm not sure the best way to proceed, or perhaps more importantly, I'm not sure of what the best final solution might be. I've heard about bumblebee - but frankly, I would prefer to have the proprietary Nvidia drivers working properly.

Any help would be much appreciated!


So I believe I've fixed it. I'll note down here what I did, in case someone (me included) needs to repeat this on an Optimus setup.

  1. Firstly, unfortunately, I needed to reinstall ubuntu. During install, I chose not to install updates during installation. Note that when it booted for the first time it still would not run unity-3d, only 2d.

  2. I added the X-SWAT ppa: sudo add-apt-repository ppa:ubuntu-x-swat/x-updates, and sudo apt-get update then I used the software updater tool. I used this rather than apt-get upgrade so I could choose which updates to install. I went through the list and ensured that there was no nvidia updates selected.

  3. I now checked installed packages, and noted that nvidia-current and nvidia settings were installed. I removed both of these.

  4. I restarted. Now, I installed mesa-utils, and restarted, and noticed that now unity-3d IS working. (hooray!)

  5. Now, just to be sure, I remove the configuration file generated by nvidia if any:

     rm /etc/X11/xorg.conf
  6. Reinstall Xorg and mesa packages... sudo apt-get --reinstall install xserver-xorg-core libgl1-mesa-glx:* libglx-mesa-dri:*

  7. Now reconfigure x-org... I'm not sure if you need to do this. I did and it didn't kill anything (I think).

    sudo dpkg-reconfigure xserver-xorg

  8. sudo reboot

  9. Now install bumblebee as directed by @Web-E above.

    sudo add-apt-repository ppa:bumblebee/stable then sudo apt-get update

  10. To install Bumblebee using the proprietary nvidia driver:

    sudo apt-get install bumblebee bumblebee-nvidia

  11. Run following

    sudo usermod -a -G bumblebee $USER

  12. And finally, sudo reboot

Note, when prompted by update manager to install nvidia-common (September 2012), I did - and it didn't break anything. I suspect that perhaps whatever bugs were present early on have been ironed out. Still... I will not install nvidia-common to begin with, but follow this tutorial above.

If anyone has any comments or suggestions as to how this method should be changed, please tell me!


  • ppa:ubuntu-x-swat/x-updates is not required for ubuntu 11.10 and newer. – Web-E May 9 '12 at 11:01
  • i think you are not using the nvidia drivers. u can check from system settings -> Details -> graphics – ggg Jul 7 '12 at 6:34
  • Not really sure what you're saying: I checked there and it says - Driver: Intel(c) Sandybridge Mobile Experience: Standard I assume this means I'm not using the NVIDIA drivers. But, that's not a bad thing right, the whole point of starting from a fresh install (See above) was to set up the graphics without NVIDIA drivers at all. – David_G Jul 8 '12 at 9:09

There is no way you can turnoff intel and work with nvidia only because the images are transported through intel card. Aim of most projects in dual graphics card is to turn off nvidia gpu and use it when required using a special command.

Intel integrated is sufficient to run unity 3d. Never install nvidia graphics card manually.

You need bublebee.

Instruction for installing Bumblebee to turn off discrete GPU and enable only when required

  1. Type the following in terminal,

    sudo add-apt-repository ppa:bumblebee/stable then sudo apt-get update

  2. To install Bumblebee using the proprietary nvidia driver:

    sudo apt-get install bumblebee bumblebee-nvidia

  3. Run following

    sudo usermod -a -G bumblebee $USER

  4. Reboot.

If you just want to disable nvidia card, no need to learn followings

Usage Instruction :

To run a program with nvidia card, use optirun command prefixed in terminal. Like to run glxspheres with nvidia card type

optirun glxspheres

To run firefox type : optirun firefox &

Note: If you intend to run 32-bit programs like Wine and using Ubuntu 11.10 Oneiric or later, install 32-bit libraries with: sudo apt-get install virtualgl-libs:i386 libgl1-mesa-glx:i386 libc6:i386

If Unity still didn't work

run /usr/lib/nux/unity_support_test-­p If unity 3d support is coming as "No", just boot with usb live disk and choose to upgrade/reinstall. This will remove extra programs you have installed but keeps all data. And will restore unity3d

Linked Questions:

How well will Nvidia Optimus cards be supported in 12.04?

Is a NVIDIA GeForce with Optimus Technology supported by Ubuntu?

Can't use nvidia card/driver on optimus notebook

  • Thanks for the prompt reply @Web-E. I have installed bumblebee as suggested. However, I still can't use unity3d - If I select that at login, it just loads 2d. The output from /usr/lib/nux/unity_support_test -p is: kakapo:~$ /usr/lib/nux/unity_support_test -p Xlib: extension "GLX" missing on display ":0". Error: GLX is not available on the system – David_G May 8 '12 at 5:28
  • Seems that nvidia-drivers are not uninstalled correctly. Best possible way is to do a fresh install. OR you can try to purge ppa of bumblebee ,remove nvidia-current,nvidia-settings. Then reboot to see if unity 3D test is successful.If sucessful, install bumblebee. I can't promise anything. as installing proprietary nvidia drivers just messes everything in hybrid graphics system. I have an dell xps with nvida 540m as optimus. First thing I did after a fresh install is to install bumblebee. Still its working without any problem. – Web-E May 8 '12 at 7:46
  • This worked for me on a Dell Latitude E6520 on 64bit version of 12.04, thanks a freacking lot! – LEOPiC Jul 16 '12 at 5:09
  • Weird, it broke after a couple of reboots, will look into it, thanks anyways. – LEOPiC Jul 16 '12 at 15:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.