0

I have dual boot win10/ubuntu-linux. i want to upgrade my Ubuntu 20.04 to 20.10. but in process, i am getting an error that says:

Efi System Partition (ESP) not usable

I've tried:

sudo mount /boot/efi

after that i got this error:

mount: /boot/efi: can't find UUID=0A0E-A110

but my linux is on sda7 with different UUID. so i got the UUID of the sda7 by:

sudo blkid /dev/sda7

Output:

/dev/sda7: UUID="fa092601-bef2-441e-92d4-2871f05e4a55" TYPE="ext4" PARTUUID="59087783-8cca-4a70-af2f-1472267b442c" the fstab file content now:

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda9 during installation
UUID=fa092601-bef2-441e-92d4-2871f05e4a55 /               ext4    errors=remount-ro 0       1
# /boot/efi was on /dev/sda2 during installation
UUID=0A0E-A110  /boot/efi       vfat    umask=0077      0       1
/swapfile                                 none            swap    sw              0       0

so i've addded this line to my /etc/fstab:

UUID=fa092601-bef2-441e-92d4-2871f05e4a55  /boot/efi       ext4    umask=0077      0       1

after that the fstab content:

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda9 during installation
UUID=fa092601-bef2-441e-92d4-2871f05e4a55 /               ext4    errors=remount-ro 0       1
# /boot/efi was on /dev/sda2 during installation
UUID=0A0E-A110  /boot/efi       vfat    umask=0077      0       1
UUID=fa092601-bef2-441e-92d4-2871f05e4a55  /boot/efi       ext4    umask=0077      0       1
/swapfile                                 none            swap    sw              0       0

I also commented UUID=0A0E-A110.

but i keep get the same error!

(Note: after some play with fstab file, got damaged and my linux boot up broke! so i logged in with a live linux and restored fstab!)

UPDATE the output of this command:

sudo parted -l

is:

Model: ATA ST1000LM014-SSHD (scsi)
Disk /dev/sda: 1000GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system  Name                          Flags
 1      1049kB  106MB   105MB   fat32        EFI system partition          boot, esp
 2      106MB   123MB   16.8MB               Microsoft reserved partition  msftres
 3      123MB   157GB   157GB   ntfs         Basic data partition          msftdata
 4      157GB   157GB   522MB   ntfs                                       hidden, diag
 5      157GB   438GB   281GB   ntfs         Basic data partition          msftdata
 6      438GB   732GB   294GB   ntfs         Basic data partition          msftdata
 7      732GB   1000GB  268GB   ext4
3
  • The EFI System Partition (ESP) is not the Ubuntu system partition. They don't have the same UUID. – user68186 May 3 at 13:18
  • 1
    Undo your changes to fstab. Plus you can only have mount to a location like /boot/efi once and it must the FAT32 partition. Post this: sudo parted -l and lsblk -f UUID of FAT32 (vfat) should be UUID in fstab. If issues it may need chkdsk from Windows or dosfsck from Ubuntu. askubuntu.com/questions/862724/grub2-failed-to-install/… – oldfred May 3 at 14:21
  • thanks @oldfred. chaning the UUID in fatab to the FAT32 one fixed my problem. – Pooya Behravesh May 4 at 9:46
1

Thanks to @oldfred.

the problem was difference between UUID of vfat (FAT32) in fstab file and the real FAT32 partition of my system. so i got the UUID of real vfat partition by:

lsblk -f

there wa this line in the output:

├─sda1 vfat     FAT32          2457-E435       

so changed the fstab vfat partition UUID to this 2457-E435 that i got above(changed the line before the last one. UUID part) :

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda9 during installation
UUID=fa092601-bef2-441e-92d4-2871f05e4a55 /               ext4    errors=remount-ro 0       1
# /boot/efi was on /dev/sda2 during installation 0A0E-A110
UUID=2457-E435  /boot/efi       vfat    umask=0077      0       1
/swapfile                                 none            swap    sw              0       0

and problem solved.

1
  • Welcome to Ask Ubuntu. I am happy that you found the answer to your question. Mark your answer as the correct solution by clicking on the gray check mark ✔ next to your answer and turn it green ✅. This will mark the problem as solved and will help others. – user68186 May 4 at 18:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.