0

I was updating my nvidia drivers from the ones that came with Ubuntu, then restarted and after it showed the Ubuntu logo it goes to a blank screen with a single blinking dash. I have read other questions like this but the answers did not work. I tried pressing escape to get to the terminal but it just printed a bunch of text and went back to the blinking dash. Control alt F2/3/etc (F10 does the same thing as escape) doesn’t do anything either, either do any of the shift keys. I don’t see how I can get to a terminal (recovery mode) or grub menu. Control alt T does not work either (does the same thing as escape). Basically I just need a way to get into a terminal.

4
  • This sounds like a "login loop". Here's how to How to boot into a root shell. You should try to revert the changes that you made that preceded the problem's onset and then reboot. – Nmath May 1 at 20:50
  • Pressing escape or shift does not work like suggested in that answer. It might be of note that I installed ubuntu on my old MacBook Pro 2010 – user2602977 May 1 at 20:53
  • This is gonna sound stupid. Press alt+ctrl+f2 to open a console shell, then press alt+ctrl+f1 to return to the graphic console, and see if the login screen shows up. – Charles Green May 1 at 22:01
  • You need to press whatever key brings you to the GRUB menu. Consult device-specific documentation if necessary. – Nmath May 1 at 23:14
1

Removing the GDM Nvidia rules works for me, with a similar problem; it may help you.

  1. Boot into a Ubuntu Live ISO, and click Try Ubuntu

  2. Open the "Disks" app

  3. In the left panel, click on your system disk

  4. In the main panel, select your root partition

  5. Click the symbol towards the bottom left to mount the parition

  6. You will see a "Mounted at" link appear next to the the "Contents" label

    enter image description here

  7. Click on this link to open the location in Nautilus

  8. From the Nautilus location bar, click the down arrow, and select "Open in Terminal"

  9. In the terminal type the following

    sudo nano ./lib/udev/rules.d/61-gdm.rules
    

    (Make sure the path starts with ./ because you want to edit the 61-gdm.rules file relative to the current mounted location).

  10. Comment out all of the lines, as shown:

    # disable Wayland on Hi1710 chipsets
    # ATTR{vendor}=="0x19e5", ATTR{device}=="0x1711", RUN+="/usr/libexec/gdm-disable-wayland"
    # disable Wayland when using the proprietary nvidia driver
    # DRIVER=="nvidia", RUN+="/usr/libexec/gdm-disable-wayland"
    # disable Wayland if modesetting is disabled
    # IMPORT{cmdline}="nomodeset", RUN+="/usr/libexec/gdm-disable-wayland"
    

    enter image description here

  11. Type CtrlX, then Y, and then Enter to save your changes and exit Nano

  12. Remove you Live ISO and reboot

8
  • I figured I’d have to use a live usb/disk. It’ll be a pain but I’ll try it. I have to get a new flash drive and use another computer – user2602977 May 1 at 21:17
  • There is a way to boot from an ISO stored on disk. (I do it regularly; that’s why there is a 5gb partition mounted in the Disks screenshot). Unfortunately, you need access to your system to set it up. Once you get your system working, you can search on this site how to boot into an ISO, in case you need it in the future. – PJ Singh May 1 at 23:51
  • I get a “directory ./lib/udev/rules.d does not exist”. Also I think I might be using Ubuntu 20.04 sorry – user2602977 May 2 at 2:08
  • This will be the same for 20.04. Did you open the terminal by clicking the down arrow in the Nautilus location bar for the ~mounted~ file system? You can check that you are in the root of the mounted file system by typing pwd and it should give you a path like /media/ubuntu/.... Also, if you type ls -l you should see the typical Linux directories in / (bin, boot, dev, etc, home, lib, mnt, opt, proc, root, etc...). If you don't see those, is it possible you mounted the wrong partition on the wrong disk? – PJ Singh May 2 at 2:16
  • If I do just sudo nano /lib/udev/rules.d/61-gdm.rules instead of ./ it opens something but only had two of those lines. Otherwise nano opens up saying no such directory. I’m guessing doing that instead does not work as it did not solve the problem – user2602977 May 2 at 2:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.