I want to remove the trash icon, the home icon as well as the drives from my desktop. I've removed them in Ubuntu 20.04, but after updating, they were there again:

I tried:

gsettings set org.gnome.shell.extensions.dash-to-dock show-mounts false
gsettings set org.gnome.shell.extensions.desktop-icons show-trash false
gsettings set org.gnome.shell.extensions.desktop-icons show-home false

No such schema “org.gnome.shell.extensions.desktop-icons”

gsettings set org.gnome.desktop.background show-desktop-icons false

No output

But all icons are still there. Any ideas how to fix this?

  • sudo apt install dconf-editor will give you a graphical interface to explore, find (complete with search feature), and adjust the same settings. – Levente May 1 at 18:22
  • Also look up how your gnome-shell extensions are called now, and whether you can spot one responsible for the feature. – Levente May 1 at 18:26
  • Thanks a lot! With your help, I found the solution. – Alwin07 May 1 at 19:12
  • You can add it as an answer, so we could also learn the solution :) – Levente May 1 at 19:13
  • Work in progress :) – Alwin07 May 1 at 19:15

Thanks to @Levente's comment I found out the solution.

There is an application called "Extensions" which lets you manage the Gnome Extensions. You can just disable the pre-installed extension called "Desktop Icons NG (DING)" and the icons will disappear:


gnome-extensions disable ding@rastersoft.com

You can actually keep DING enabled. Then right-click the desktop and select the last item: "Desktop Icons settings". There you can control what DING does, for example remove the home and wastebasket icons :)

  • This is the way. – solr Jun 6 at 6:42

To hide the trash and home icons:

gsettings set org.gnome.shell.extensions.ding show-trash false
gsettings set org.gnome.shell.extensions.ding show-home false

To additionally hide the external drives:

gsettings set org.gnome.shell.extensions.ding show-volumes false

Slightly off-topic, but I think it's nice to show hidden files when they are in the Desktop (so I can remove them or process them accordingly since in my workflow typically hidden files should not be there):

gsettings set org.gtk.Settings.FileChooser show-hidden true

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.