Like the title says I have been at this all day. I have partitioned my disk to no avail. When I boot to Ubuntu I get two options (remove partitions on hard drive or something else) I only get the third option, install along side Windows, when I have my 16 gb usb inserted. I have a usb bootable on a 8gb and a dvd. When I elect "something else" I get options like


dev\sda1 1 mb

...sda2 250 gb

...sda3 219 gb

...sda4 32 gb

I partitioned only 20 gb!!! Why is it not displayed by Ubuntu?

Then I bow down and use wubi to NO avail. I have choosen all three options and each one has resulted in an error.

I have no idea what to do...any ideas?

I am running windows 7 premium and now have my hdd partitioned 4 ways. It didn't work with three either btw.

  • How did you partition your hard drive? What are the partitions you want to have? Do you have windows or other OS on the hard drive? – G. He May 8 '12 at 0:40
  • Please provide more information- what is your system configuration? Are you dualbooting? Triple-booting OSes? Or just letting the installer choose how to partition your disk? – papashou May 8 '12 at 0:42
  • When you say you have partitioned your disk, did you do that through Windows, or using a third-party utility? Just for future reference, it's usually better to leave your disk unpartitioned, and just let the Ubuntu installer do the partitioning. – Marius May 8 '12 at 0:46

A hard drive can only contain 4 primary partitions. When I first tried to install 11.10 in a new Dell with Win7 I wanted to have an independent partition for my data --been doing that for many years and has saved me from unimaginable grief! Then I found that the machine came with 3 factory set partitions, one for the MBR, another for the recovery image and the third for the W7 OS. After I had created the data partition I was left with no options.

My solution was to create rescue DVD's from the rescue partition and then delete that (using GParted from my Ubuntu LiveCD (a bootable USB memory actually). Once that was done, I moved Win7 to close the gap as I didn't fancy having some 12GB of unused space between the boot partition and Windows. This took several hours; I went to sleep and left the machine working, next morning that was done.

With that obstacle behind, I could install Ubuntu by creating an empty Ext4 primary partition.

Seeing that you have already 4 partitions, I believe that might be your case.

Please let me know if this helped.

  • I see now that you had only three partitions. I think that somehow the 32GB one might be the one you created last. Can you run GParted from the LIve CD and check what format is it? In case it's NTFS, go to windows and check if it finds it. See what's there (should be empty). Boot again the LIve CD and delete it. Leave its space empty. You should be able to install Ubuntu there by using the Something Else option. Just point the Grub installation to dev/sda (no number, it means the primary drive) and Ubuntu's mount point to dev/sda4 / with Gparted. – Jorge M. Treviño May 8 '12 at 1:18

Try the server installer, and press F6 to choose nonmodeset, then Escape, and try it then. Worked for me!!!

  • This is related to disk, not display. – nanofarad Aug 16 '12 at 23:21
  • no, the server install is like terminal and not graphical mode, kinda like bios – Nick Bailuc Mar 10 '13 at 7:29
  • No, the OP is having a disk problem. – nanofarad Mar 10 '13 at 13:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.