0

I have a Sandisk 128GB USB drive which appears totally unreadable in Windows 10. When queried, the drive will lock Windows File Explorer up, and sit there until the USB is removed. I tried this on three Windows machines.

I booted Ubuntu 20.04 and the USB drive then became readable. The drive was then backed up onto a HD partition folder. I assume it copied everything, but how can I recover the drive content aside from hard formatting it?

I ran both dosfsdk and fsck.vfat several times on it, but they both always appear to terminate early with just a GOT nnnn bytes instead of xxxxx message.

The following is the latest terminal output:

aqk@Giga-Ubuntu:~$ sudo dosfsck -a -t -w -r -l -v /dev/sdc1       
[sudo] password for aqk: XXXXXX    
fsck.fat 4.1 (2017-01-24) 
Checking we can access the last sector of the filesystem 
Boot sector contents:   
System ID "        "   
Media byte 0xf8 (hard disk)     
        512 bytes per logical sector    
      32768 bytes per cluster        
         14 reserved sectors 
First FAT starts at byte 7168 (sector 14)  
          2 FATs, 32 bit entries   
 15159808 bytes per FAT (= 29609 sectors) 
Root directory start at cluster 2 (arbitrary size) 
Data area starts at byte 30326784 (sector 59232)   
  3789922 data clusters (124188164096 bytes) 
63 sectors/track, 255 heads 
    2 hidden sectors  
242614240 sectors total     
***Got 6743040 bytes instead of 15159696 at 7168***            

Are there any other utilities that can recover this USBdrive "as is", or will I be forced to fully format it?

1
  • 4
    I wouldn't try and fix, just copy the files off the device (and for sure verify the data integrity of them as I'd not trust it until verified) and then format the device.. Flash media is built for cost (with no self-checks etc built-in unlike other media types), and that's why we keep backups of data that is important to us.
    – guiverc
    Apr 29, 2021 at 0:23

2 Answers 2

0

Don't bother fixing the USB stick. They all eventually flake out. They are not for long-term storage. More like for moving presentations around, that'd be about it. If it's still under warranty, Sandisk might send you a new one. You saved the files from it, that's what counts.

1
  • Thanks! (lol) For making me see the light. You're right- it's just a USB stick. Last price was ?? $15? I was helping someone else and had already told them to buy TWO such disks and keep a bkup! It was basically just an intellectual query....
    – aqk
    Apr 30, 2021 at 2:47
0

The environment consists of a Ubuntu system, a Windows systems and a large 'thumb' drive which is acting weird. The objective is to be able to use the existing content of the large thumb drive in a windows environment. The Ubuntu system is able to access files on the large thumb drive.

It is assumed there is 128GB of free space on either the Ubuntu system or the Windows system.

A fix:

  1. Create a share on either the windows system or the Ubuntu system.
  2. From the Ubuntu system, copy the contents of the thumb drive to the share
  3. Format the large thumb drive, probably on the Windows system
  4. Copy the saved contents onto the reformatted thumb drive
  5. Verify the thumb drive contents is good
  6. (optionally) erase the shared copy
  7. (optionally) stop sharing the created share
1
  • Done that. Except the reformat of the USB drive. And actually have backed it up off-site to a Raspberry SSD as well. I'll tell the user to next time format the USB as NTFS instead of FAT32. I would suggest EXT4, but....
    – aqk
    Apr 30, 2021 at 2:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.