0

So I had a working well 3 working systems using Hyper machine and running 3 Ubuntu CLI servers. Then I did an update and something buggy happened on 2 of the 3 servers. I stopped when 2 of them went offline and did not update the last one. NOW I can not get the eth0 interface to connect to the network. Thankfully I have access via the terminal thru the hyper manager but that is the ONLY way I can run commands, ssh will not work because the interface reports as unmanaged. With the thousands of issues posted online about network manager, I have probably made it worse trying to fix it. The netplan shows the interface settings but it won't activate and won't show an up status with nmcli. BEFORE the update from Ubuntu it was working fine with the current settings. So now I need help to figure how to change settings via CLI exclusively and what folders to check for this problem as it seems that there was a major change to the way the interface is managed, from a once-great working method to something that someone thinks it should now be changed to. The setup was working perfectly using the previous method. So I have no clue where to start since I have tried many solutions online that have not done what the suggestions claim to do. Is there anyone up for a challenging network-related problem?

I would reinstall but I made some changes that I do not want to redo on how the applications worked to store and retrieve data from the NAS on the network, so I am not really wanting to have to google the commands again to redo those changes for this simple prblem according to what I see online about this bug. One is an apache server the other is a xeams email server.

9
  • Hi ... pls post output of "nmcli devices show" and 'ip addr". Use pastebin ?
    – MarcoZen
    Apr 28 at 7:53
  • does not provide output to invalid devices command Terminal will not copy t clipboard. No SSH session either.
    – Chris Owen
    May 1 at 6:48
  • U mean there is no output when you type in 'ip addr' ?
    – MarcoZen
    May 1 at 10:05
  • There is output with ip addr but I can not save it to a clipboard. the other command does nothing.
    – Chris Owen
    May 2 at 9:13
  • If you still havent solved yr prob;em yet, then type out the output here. The plan is to use that info and add that interface back up using nmcli. Do also show output of 'nmcli device show' as well.
    – MarcoZen
    May 2 at 13:48
0

From the screenshot you sent, I see that you dont have Network Manager ( nmcli ) installed.

I am suggesting you install that, get info on the interfaces you have present and create a working network connection.

Follow the steps below ...

: Update Package List:

sudo apt update  

: Install Network Manager :

sudo apt install network-manager

: Enable Network Manager :

sudo systemctl enable NetworkManager.service

: Start Network Manager :

sudo systemctl start NetworkManager.service

: Ascertain the detected interfaces :

sudo nmcli device status 

: Create A Network Connection - Based on devices you noted above ,say eth0 :

sudo nmcli connection add type ethernet con-name some_name_you_like ifname eth0 ip4 10.10.10.10/24 gw4 10.10.10.1

: Check your DNS Settings :

sudo nmcli connection show "the_name_from_above" | grep ipv4.dns

: Add Quad9 DNS :

sudo nmcli connection modify "the_name_from_above" ipv4.dns "9.9.9.9"

: Test :

sudo nmcli connection show "the_name_from_above" | grep ipv4.dns
ping askubuntu.com
6
  • pasteboard.co/K1Ep3BJ.png Looks to already be installed, tried some commands after and nothing worked.
    – Chris Owen
    May 13 at 4:41
  • Hi, from the screenshot, you did not follow the commands i gave you ? Did you do commands 1 -4 ? Bcos your screenshot shows that you did not ? ..... Cant help you if you wont follow instructions ... use sudo, enable network manager , start network manager etc ....
    – MarcoZen
    May 13 at 8:21
  • Yes the update failed to get anything from online. The install could not get online to download the netmanager since it apears to be installed already and enable and starting the service failed. I had thought i was sudo su
    – Chris Owen
    May 14 at 9:17
  • @ChrisOwen - The screenshot shows that NetworkManager was not running. So you havent started it yet or it failed to start. Only way to know is to run command 3 & 4. Next the screenshot also shows that that you are NOT running the commands as root. So pls use sudo. Look - help yourslef and follow commands 3-7. Show the output of any command that is problematic.
    – MarcoZen
    May 14 at 10:08
  • So this buggy version of Ubuntu won't run the network due to some change in the way the network functions and no matter what I have tried the screenshot that I sent is the exact same under sudo, sudo su as well. So I am going to abandon this bug-filled 20.0 version of the server and rebuild from scratch as getting help takes days to get an answer to a question about how to revert back to a previous unpatched version that does not have the bug network manager that was updated and molested for no reason that I can figure out since it was working until I did a sudo update sudo upgrade .
    – Chris Owen
    Jun 9 at 6:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.