I have a new Apple Macintosh laptop and I am trying to use Samba to send files back and forth from my Ubuntu Mate laptop and vice versa. I am not familiar with Samba or with modern Macs. I am pretty familiar with Linux. There are no Windows machines in my network.

My user name is Bob on the Mac and bob on Ubuntu Mate. The passwords for logging on as the user are the same on both machines.

I have turned on File sharing on the Mac and set the weird option to make the password for Bob to be usable by Windows.

On the Mac I went to System Preferences->Network->WiFi->Advanced...->WINS->Workgroup and changed the Workgroup to HOME (having first changed the WINS server to the IP address of the Ubuntu Mate).

On Ubuntu Mate I changed workgroup to HOME in /etc/samba/smb.conf.

On the Mac, in Finder I can go to the network and I can see the Ubuntu Mate machine and can connect as Guest. (I can't see any folders, possibly because I haven't explicitly set any up to be shared for guests.)

On the Mac, if I try to connect as Registered User, it supplies the user name "bob" and asks for the password. I type the password and click Connect. The dialogue box shivers and asks me again, obviously not accepting the password and/or user.

On the Ubuntu Mate, in caja, I can use the Browse Network bookmark and the name of the Mac appears. If I double-click on the Mac's icon, I get a dialogue box that fills in Username as bob; Domain as HOME and asks for Password. The dialogue box vanishes and reappears, obviously not accepting the password and/or user. If I change the Username to Bob (with capital B) the same happens. There does not seem to be a way of connecting to the Mac as guest.

Any ideas how I can connect as Registered User in either direction?

  • 1
    You really seem insistent on forcing this Mac-Linux connection to use NetBIOS. MacOS-Linux uses mDNS ( Bonjour in Mac, Avahi in Linux ). No need for workgroups, WINS servers, etc... anyhoo ... you need to do on Linux what you did on MacOS: Add bob to the samba password database: sudo smbpasswd -a bob
    – Morbius1
    Commented Apr 27, 2021 at 11:16
  • You're right. I suppose I'm a bit fixated on Samba. It's partly because Apple pushes you in that direction. Anyway, I used the smbpasswd command. I can now connect from Mac to Ubuntu as bob. I can't see any files yet, but I guess I have to read the Samba manual for that. Ubuntu to Mac still fails. Commented Apr 27, 2021 at 13:48
  • By the way, is Bonjour/Avahi easier for file transfer? I googled "How use Bonjour to access files from MacOS to Ubuntu" and the answers all seemed to mention Samba, ssh or afp. Commented Apr 27, 2021 at 13:50
  • Samba doesn't require NetBIOS it can announce and discover all MDNS based systems ( except Windows 10 ) automatically in it's file manager. That's why they all resolve to hostname.local. It is still samba it just discovers them all without NetBIOS.
    – Morbius1
    Commented Apr 27, 2021 at 13:50
  • Bonjour / Avahi isn't a file transfer protocol. It is a host name resolution protocol.
    – Morbius1
    Commented Apr 27, 2021 at 13:53

2 Answers 2


Yes, I know I can refer to something.local for example to look at web pages on other machines. But neither caja nor Finder allow me to use that syntax to access other devices

Of course it does. If I open up Caja > Browse Network I see my MacOS SMB server: enter image description here

If I double click that I enter credentials for someone on the Mac ( in your honor I created a user with a Capital letter and entered a just made up Domain name which matches noting on my network:

enter image description here

Then with some drill downs I can access "Pat's" Public folder: enter image description here

All done with mDNS. And your can always use Connect to Server in either Caja or Finder to connect explicitly: enter image description here

  • I was getting confused or pedantic. Yes, I can see the icon "something" in caja (but not something.local). If I were able to connect to it, I expect I would see something like smb://something.local/.... in the window. I notice you refer to your MacOS SMB server. Did you have to set that up, or does that functionality work straight out of the box with Macs? By the way, thanks for all your help. Commented Apr 27, 2021 at 14:56
  • I set that up on the Mac the exact same way you did in your other question: System Preferences > Sharing > File Sharing > ... SMB. What I didn't do is mess around with workgroups, WINS servers and whatever else you changed. THen I added Pat to the password database on the Mac and bada bing bada boom.
    – Morbius1
    Commented Apr 27, 2021 at 15:08
  • Thanks. Samba is running out of the box (I think) on the Ubuntu Mate. After I had edited /etc/samba/smb.conf to use HOME as Workgroup, allow access to users home directories and then restarted smbd and run the smbpasswd command, I was able to access my files on UM from the Mac. Commented Apr 29, 2021 at 17:26
  • I then tried copying what you did. On UM I created a new user pat. I ran the smbpasswd command. On the Mac I created a new user Pat and set the weird option to make the password for Pat to be usable by Windows. I can access Pat's folders on UM from Mac, but trying to access Pat's data on Mac from UM failed again. Commented Apr 29, 2021 at 17:34
  • You didn't need to add pat to the Linux box and you didn't need to change the workgroup on the Mac. I would suggest a different approach to access the Mac since we seem to be at a dead end with SMB on the Mac. See my other answer.
    – Morbius1
    Commented Apr 29, 2021 at 20:24

I can't reproduce the symptom you have with accessing the SMB server on the Mac. Since Samba works in reverse ( Mac to Linux ) use something different to access the Mac.

On the Mac: System Preferences > Sharing > enable Remote Login

On Linux: Open Caja > Browse Network > You should see the Mac host name with a ( Remote Login ) label attached. Click on that, provide a user name and password and you should have access like this:

enter image description here

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .