1

I just put together a new PC and put an 11th gen (Rocket lake) intel CPU, i5-11400. It is supposed to have Intel UHD Graphics 730. I installed the just-released ubuntu 21.04.

But the display shows as UNCLAIMED, and I can't change the resolution, and when I try to hook up 2 monitors, the resolution decreases dramatically. It seems to me there's a problem with the driver.

Is the Intel UHD Graphics 730 driver not available in linux yet? I read that they didn't even release the driver until a few weeks ago. Looking back at similar issues over the past few years, it seems it may take awhile for this processor to support linux graphics. If that's the case, does anyone know how long that usually takes?

sudo lshw -c video
  *-display UNCLAIMED       
       description: VGA compatible controller
       product: Intel Corporation
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 04
       width: 64 bits
       clock: 33MHz
       capabilities: pciexpress msi pm vga_controller bus_master cap_list
       configuration: latency=0
       resources: memory:b0000000-b0ffffff memory:a0000000-afffffff ioport:4000(size=64) memory:c0000-dffff
2
  • The next release of Ubuntu, with an updated pre-compiled kernel, will be in six months: October 2021. If you don't want to wait for that, then try a more bleeidng-edge distro or learn how to compile your own kernel. – user535733 Apr 27 at 1:23
  • @user535733 even the most "bleeding edge" kernels aka "linux-next" which are released almost daily do not support graphics or 2.5gb ethernet for the Z590 chipset. In fact nothing is supporting the 2.5gb networking but the 5.10.0-1023-oem kernel IS at least supporting the graphics. – rsr911 May 8 at 4:20
1

This question has sort of been answered in a question concerning a blank screen. The solution is to install the 5.10 oem kernel. But that caused me to have another problem, my 11900k only turbos to 4.7ghz because for some reason the "powersave" governor in the kernel won't let it go higher. My workaround has been to use cpupower-gui and set all cores for 5.3 and change the governor to "performance" but that keeps the cpu revved up around 5k and about 5C hotter. BUT both of my monitors work even expanding the desktop.

sudo apt install linux-oem-20.04b -y
sudo apt install cpupower-gui -y

run cpupower-gui by typing it into the terminal. You will want to boot into the new kernel first of course and get your monitors working properly.

UPDATE 4/30/2021. I've upgraded to 21.04 but kept the 20.04b kernel. It complains about binaries when installing software but it runs. Today I updated my Asus Z590 Rog Strix bios from 0704 to 0707 and the cpu frequency issue went away, so no need to install cpupower-gui if you don't want to.

Update: 5/8/2021. I have discovered if I used "i915.force_probe=4c8a" in grub with 5.12, 5.12.1, 5.12.2, linux next, kernels etc I can boot ONE monitor only. For dual monitors using both ports I still must run the 20.04b (5.10.0.1023-oem) kernel.

5
  • Thanks! -- but it looks like linux-oem-20.04b is not available in repos for 21.04 -- only for 20.04... I tried installing linux-oem-20.04 which updates to kernel 5.11, but this doesn't solve the problem. Apparently a version of 5.10 works, but 5.11 does not: forums.linuxmint.com/viewtopic.php?f=59&t=345452 – nsheff May 1 at 1:39
  • See above. I was able to keep my 20.04b kernel after upgrading. Just updated my answer. – rsr911 May 1 at 3:15
  • Download the .deb package: packages.ubuntu.com/focal/amd64/linux-buildinfo-5.10.0-1023-oem/… Or here is the repository you can add to your sources: deb security.ubuntu.com/ubuntu focal-security main – rsr911 May 1 at 4:53
  • Updated that single monitors work with the latest mainline kernels but dual monitors still do not. – rsr911 May 8 at 7:20
  • 1
    Thanks, following your guidelines I was able to get this to work. I had first updated to the latest kernel, but as you mention, it didn't work; I was then able to downgrade to that particular kernel (5.10...) and then it worked. Thanks for your insight that pointed me in the right direction. – nsheff May 11 at 14:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.