341

This started to happen immediately after I had rebooted the first time after doing a system upgrade. It first starts with a dialogue that says "System program problem detected". Then when I try to hit 'report problem' not much happens. I am led through a dialogue that always ends up the problem cannot be solved.

I am aware this is not a lot of information, however I'm not sure which information I need to publish and how should I obtain it to debug this problem.

Here's a screenshot! enter image description here

384

Open a terminal (Ctrl+Alt+T) and type:

sudo rm /var/crash/*

Then hit Enter.

This will remove any old crashes, that might still be reported (in error). After a reboot/re-starting, any further pop-ups still need to be investigated.

  • 2
    Genius! Concise yet precise. This also happens every time you switch between kernels in the same OS. – Ébe Isaac Apr 22 '16 at 3:53
  • wow, actually that is the best awnser i saw until now for this issue, it works and as a bonus keeps apport enabled, also now i see the real issues i have – spider623 Jun 26 '16 at 23:27
  • 17
    It is disturbing that old crash reports can trigger more crash reports – prusswan Mar 30 '17 at 9:22
  • 1
    Add this to run on boot up in cron find /var/crash -mtime 1 -delete and it will delete crash reports older than a day. This means you can finally hit Cancel and the thing will go away. Annoying that Cancel means nag-me-later. – artfulrobot Mar 24 '18 at 8:26
  • I came here from Google so I guess it's worth commenting on an old answer. So how does it really work? If crashes occur, the system creates files in /vat/crash/. Then apport notifies about any crash that is ready to investigate. Is that correct? – Celdor Mar 11 at 11:40
133

Disabling error-reporting is not a desirable solution!

Ubuntu has an error reporting system called apport which tries to catch all program crashes in the background and report them to help the developers.

It seems that after a dist-upgrade there are some stuck reports that continue to display for unclear reasons, but disabling apport is not a desirable solution.

Remove old crash-reports

Open a terminal and remove all old crash-reports that might exist in the crash-report directory:

sudo rm /var/crash/*

After a reboot the popups are gone.

If you don't want to reboot, you can close all open popups with:

killall system-crash-notification

(Any further new pop-ups still should be investigated. If you want to see the details,
look in /var/crash/ for any new reports)

  • 47
    If the developers don't want people to disable error reporting, they should probably make it work right. This seems to be a long-existing and very visible bug. Still, this is a good answer. – nobar Nov 16 '14 at 22:57
  • 2
    Upvoting because of how many people don't understand first line of your post. – Błażej Michalik Apr 3 '16 at 2:38
  • 14
    @BłażejMichalik: For what it's worth, error message boxes that do not provide the slightest hint as to what error has happened (or how to find out more about that error) are not a desirable solution, either. – O. R. Mapper Dec 2 '16 at 12:55
  • 2
    @O.R.Mapper I agree, but disabling error reporting altogether is worse. Apport n' chap's verbosity is a different problem, to which there is probably no real solution right now. – Błażej Michalik Dec 2 '16 at 14:19
  • 7
    It's a UX error to bug the user with a pointless dialog that keeps popping up. Add options Yes from now on and No from now on. And somehow allow me to figure out what sort of error it is. The extra screens are not very helpful. – Reinier Post Dec 8 '16 at 12:14
58

Here's how to disable Apport, the system that reports errors to Canonical:

Open your terminal and type:

gksudo gedit /etc/default/apport

And hit Enter.

Change enabled=1 to enabled=0, then save and exit.

To solve this problem, you can watch this YouTube video.

See also: How do I enable or disable Apport?

14

I have had the same problem when upgrading from 12.04 to a higher version. As it turns out, Ubuntu has an error reporting system called "apport", which was deactivated in stabled releases of Ubuntu until 12.04 and is reactivated now.

Manuel Jose has made an excellent quick-guide how to turn off the error reporting in apport

1

If you would like to turn off the config setting without using a GUI:

sudo crudini --set /etc/default/apport '' enabled 0
  • sudo -k sed -i -r 's"enabled=1"enabled=0"' /etc/default/apport – Aquarius Power Mar 28 '17 at 22:54

Not the answer you're looking for? Browse other questions tagged or ask your own question.