42

Keyboard shortcuts in gnome-terminal (Ctrl+Tab and Ctrl+Shift+Tab) in 12.04 don't seem to be working. Is there a setting that I dont know of?

7 Answers 7

79

A way to configure this is by setting gsettings from the terminal itself (two commands):

gsettings set org.gnome.Terminal.Legacy.Keybindings:/org/gnome/terminal/legacy/keybindings/ next-tab '<Primary>Tab'
gsettings set org.gnome.Terminal.Legacy.Keybindings:/org/gnome/terminal/legacy/keybindings/ prev-tab '<Primary><Shift>Tab'

Source: the last comment in the bug report

7
  • 2
    Exactly what I was looking for. Simple, effective, trivial to implement. This answer needs more upvotes.
    – Nickolai
    Commented Mar 1, 2018 at 3:19
  • 1
    Fantastic, thanks. The option no longer appears in dconf editor (in 18.04) as I answered above, but this works.
    – apostl3pol
    Commented Sep 11, 2018 at 4:29
  • 2
    This should be the accepted answer. Works in Ubuntu 19.10. Commented Feb 11, 2020 at 21:32
  • Works on Ubuntu 20.04, too!
    – bteo
    Commented May 26, 2020 at 7:26
  • 1
    Works on Ubuntu 22.04. Thanks a lot.
    – Vahid Al
    Commented Aug 1, 2022 at 14:01
25

Use dconf Editor. If it's not installed by default you can get it with sudo apt-get install dconf-tools. The shortcut can be modified at Org > Gnome > Terminal > Legacy > Keybindings.

Screenshot of dconf Editor

This works for me in Ubuntu Gnome 16.04. Reference: https://bugzilla.gnome.org/show_bug.cgi?id=738325

4
  • This should be the accepted answer. Commented Dec 29, 2016 at 10:33
  • 10
    You can do this without installing anything using dconf write /org/gnome/terminal/legacy/keybindings/next-tab "'<Primary>Tab'" and dconf write /org/gnome/terminal/legacy/keybindings/prev-tab "'<Primary><Shift>Tab'" Commented Jan 20, 2017 at 23:15
  • Just verified for Ubuntu 18.04 and 20.04 works without any issues. Commented Jun 15, 2020 at 20:36
  • This actually worked when gsettings didn't
    – k_g
    Commented Aug 23, 2021 at 19:09
18

Unfortunately assigning shortcuts with TAB key is a no go in Gnome (for whatever reason). So this will not work.

There is a way to do this in a hacky way, from the answer below type this in the terminal:

gsettings set org.gnome.Terminal.Legacy.Keybindings:/org/gnome/terminal/legacy/keybindings/ next-tab '<Primary>Tab'
gsettings set org.gnome.Terminal.Legacy.Keybindings:/org/gnome/terminal/legacy/keybindings/ prev-tab '<Primary><Shift>Tab'
7
  • 5
    it is really uncomfortable to not have ctrl-tab. Thanks for that though, ive already learned to live without it. I should use ctrl-~ and ctrl-shift-~ now.
    – PnotNP
    Commented May 9, 2012 at 21:09
  • I tend to learn the native shortcuts and use those. So for gnome-terminal it's ctrl-shift-right & ctrl-shift-left Commented May 9, 2012 at 21:20
  • Another follow up mail.gnome.org/archives/desktop-devel-list/2009-November/…
    – Braiam
    Commented Aug 28, 2013 at 3:17
  • 1
    That bug report says it's RESOLVED FIXED, yet the problem seems to exist. Was it just reported fixed without doing anything? Commented Dec 11, 2013 at 0:25
  • I have my caps-lock mapped to escape through the OS and then I use Ctrl+Esc for next tab, so on the keyboard I am actually pressing Ctrl+Caps Lock for next tab. Commented Aug 4, 2015 at 18:06
3

Use Ctrl+PageUP and Ctrl+PageDown (annoying, but it is what we have).

1
  • I tried setting <Primary>Tab for mate terminal with dconf. org/mate/terminal/keybindings/next-tab. It works to change the setting with dconf but mate terminal thinks the shortcut is invalid for some reason. But <Primary>Tab seems to work with gnome terminal. Commented Feb 26, 2021 at 7:38
1

This may be a little heretic to do in gnome but you can install Konsole and have those shortcuts like so:

sudo apt install konsole

The shortcut Ctrl+Tab is set by default.

Note: Konsole is the KDE default terminal

0

One thing very interesting I found days ago is that the gnome does:
- Ctrl+Tab Switch between different application
- Ctrl+`(The one above Tab) Switch between different windows of one application
Try this.

0

Resetting the dconf to 'factory setting' might help sometime(At least in my case when my Ctrl+T was not working system wide)

dconf reset -f /org/gnome/

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .