After activating the default AppArmor profile for Firefox, links in e-mails on Thunderbird no longer work.

Expected behavior: When I click on a link in Thunderbird, Firefox starts (if necessary) and goes directly to the URL specified by the link.

Actual behavior: When I click on a link in Thunderbird, Firefox starts with an empty address bar, does not load any URL, and Firefox hangs. At that point, I have to kill Firefox from the command line. At this point, dmesg shows the following errors:

How do I instruct AppArmor to allow Firefox to load links clicked in Thunderbird?

Details: Ubuntu 20.04.1, Firefox 87.0, Thunderbird 78.7.1, default AppArmor profile from /etc/apparmor.d/usr.bin.firefox


1 Answer 1


Note: This solution originally appeared to work, but it no longer does. I am still looking for a solution.

After hours of fruitless messing around with Firefox's AppArmor profiles, I found an unrelated solution that works.

  1. In Thunderbird, go to Menu > Preferences > General, scroll to the bottom, and click on Config Editor.
  2. Search for network.protocol-handler.warn-external.http, and double-click to change from FALSE to TRUE.
  3. Repeat for network.protocol-handler.warn-external.https.
  4. Close the Config Editor and Preferences.
  5. Click on a link in an e-mail. You will see a popup asking you to select which browser to open the link in. Select Firefox, check the box that says "remember my selection" (or somesuch), and click go.
  6. Your links should now open in Firefox without problem.

What undesirable side-effects this solution will have I cannot say, but it appears to work for me.

  • This has stopped working. I am still looking for a solution.
    – Bolio
    Apr 26, 2021 at 11:07

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .