I installed Ubuntu 21.04 in a Hyper-V VM on Windows 10. It appears to be working great!

I then followed the awesome directions here:

How to install Ubuntu 20.04 on Hyper-V with enhanced session

'Enhanced session' support allows for things like full-screen and multiple monitor support.

This also appears to be working well!

Side note about the instructions there

Edit xrdp.ini

The directions there say:

If you receive an error at the end of the install script, there is one more thing to do. Using your favorite editor, open /etc/xrdp/xrdp.ini

I didn't receive an error, but in order to get the enhanced session support to work, I did have to edit xrdp.ini as he directs.

Hyper-V Quick Create

I used 'Hyper-V Quick Create' to create my VM. I didn't go through all the manual steps he describes there involving UEFI. The VM appears to work fine.

OK, onto the rest of the context for the question.

Full Screen

If I move the size slider all the way up:

enter image description here

it launches full screen which is nice.

My monitor resolution is 3840x2160 so increasing the display scale is desired. When I do so as follows:

enter image description here

it works fine.

Use all my monitors

Now, let's say I log out and reconnect. This time, I select 'Use all my monitors':

enter image description here

Amazingly, this works! I get a desktop across two external monitors and the laptop display. Three screens in all!

This time however, if I go to increase the display scale to 200%:

enter image description here

I hit 'Apply', then 'Keep Changes' in the 'Keep these display settings' dialog. However, it appears to immediately revert to 100% scale.


Is there a way to increase the display scale when connected via the 'Use all my monitors' option?

  • 1
    Excellent question to which I have yet to find an answer. I won't be surprised if there isn't one, given how flimsy scaling is in Gnome. It baffles me how something that was working fine, even fractionally, years ago in Unity can still be an issue now. Apr 24, 2021 at 13:34


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy