3

Can someone help me to install drivers for my Nvidia GPU RTX 3080 on Razer Blade Advanced 2021?

I'm curious if I did something wrong during the fresh installation. (Everything was working fine on Ubuntu 20.04 LTS)

Original issue: The second monitor is not detected on Wayland

I've tried following code and got this message:

spartan@razer-lt:~$ ubuntu-drivers devices
== /sys/devices/pci0000:00/0000:00:01.0/0000:01:00.0 ==
modalias : pci:v000010DEd000024DCsv00001A58sd00002016bc03sc00i00
vendor   : NVIDIA Corporation
model    : GA104M [GeForce RTX 3070 Mobile 16GB]
manual_install: True
driver   : nvidia-driver-460 - distro non-free recommended
driver   : nvidia-driver-460-server - distro non-free
driver   : xserver-xorg-video-nouveau - distro free builtin

spartan@razer-lt:~$ sudo ubuntu-drivers autoinstall
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
nvidia-driver-460 : Depends: nvidia-dkms-460 (>= 460.73.01)
                    Depends: nvidia-kernel-common-460 (>= 460.73.01) but 460.67-0ubuntu1 is to be installed
                    Recommends: nvidia-settings but it is not going to be installed
                    Recommends: nvidia-prime (>= 0.8) but it is not going to be installed
                    Recommends: libnvidia-compute-460:i386 (= 460.73.01-0ubuntu1)
                    Recommends: libnvidia-decode-460:i386 (= 460.73.01-0ubuntu1)
                    Recommends: libnvidia-encode-460:i386 (= 460.73.01-0ubuntu1)
                    Recommends: libnvidia-ifr1-460:i386 (= 460.73.01-0ubuntu1)
                    Recommends: libnvidia-fbc1-460:i386 (= 460.73.01-0ubuntu1)
                    Recommends: libnvidia-gl-460:i386 (= 460.73.01-0ubuntu1)
E: Unable to correct problems, you have held broken packages.
spartan@razer-lt:~$ 

EDIT 1: I can't select a different driver either. During the installation, I've ticked the box to install 3rd party drivers, tools... Software & update center

Thank you in advance!

8
  • Yes, your output has a classic indicator that you did something wrong: Some packages could not be installed. This may mean that you have requested an impossible situation. It means that somewhere, at some time, you have explicitly told your system to install packages that are incompatible with your system. You must uninstall those packages to resolve the version conflict.
    – user535733
    Apr 23, 2021 at 11:14
  • There is no tested, supported release-upgrade path directly from 20.04 to 21.04, which suggests that a backup-and-reinstall might be the recommended solution if you're not skilled at untangling Debian package dependencies yourself. Alternately, this situation is exactly how folks learn those skills.
    – user535733
    Apr 23, 2021 at 11:21
  • Yes 21.04 is released but it has not been added to the automatic prompt to upgrade on running systems yet. The pop up you get that says you are up to date but a new version is out. Personally I am waiting for that.
    – David
    Apr 23, 2021 at 11:25
  • Adding to all the great advice above, when you're installing 21.04 from scratch, please enable the installation of third-party drivers, codecs, etc. as this will automatically install the Nvidia drivers you need. And don't forget to disable Secure Boot in UEFI. Apr 23, 2021 at 11:41
  • 1
    It is a fresh install of Ubuntu 21.04. I've also ticked the box to install 3rd party drivers, codecs...If I understand well comments, it means I need to wait for an update from Nvidia (support for 21.04)? Or there is some way to get Nvidia drivers for this release? Apr 23, 2021 at 14:06

3 Answers 3

1

Little late for this but I just encountered this issue and I fixed it by reinstalling the Nvidia drivers:

sudo apt reinstall nvidia-driver-460

I didn't install anything that could cause this issue but Ubuntu had a few updates and it happened after that.

0

First open the Synaptic and try to reinstall this packages with problems. Second annotate the name packages with problems and purge it, after install these packages. Third if it doesn't function, you can try to install these drivers that don't are possible to select using the terminal, my post explain better How to do it. Remember to do backup (I recommend doing backup on Timeshift) before to install anything use: sudo apt-get install name (program, package, driver, etc), I explain better in this post: How I do to the driver to install/upgrade automaticly? And manually?

0

The final solution was simply to reinstall Ubuntu 21.04. I guess some new updates come during the night and fixed the problem with Nvidia GPU cards.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.