1

I'm trying to apt upgrade my system, but it fails with:

You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 ubuntu-server : Depends: motd-news-config but it is not installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

So I try apt --fix-broken install which shows:

The following additional packages will be installed:
  base-files motd-news-config
The following NEW packages will be installed:
  motd-news-config
The following packages will be upgraded:
  base-files

But it fails with:

Preparing to unpack .../base-files_10.1ubuntu2.10_amd64.deb ...
Warning: Stopping motd-news.service, but it can still be activated by:
  motd-news.timer
Unpacking base-files (10.1ubuntu2.10) over (10.1ubuntu2.9) ...
dpkg: error processing archive /var/cache/apt/archives/base-files_10.1ubuntu2.10_amd64.deb (--unpack):
 unable to create '/usr/bin/locale-check.dpkg-new' (while processing './usr/bin/locale-check'): Operation not permitted
Reinstalling /etc/default/motd-news that was backed-up
motd-news.service is a disabled or a static unit, not starting it.
Errors were encountered while processing:
 /var/cache/apt/archives/base-files_10.1ubuntu2.10_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

So finally I try apt install motd-news-config but it fails with:

The following packages have unmet dependencies:
 motd-news-config : Breaks: base-files (< 10.1ubuntu2.10) but 10.1ubuntu2.9 is to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

I don't understand what's going on here. It seems that the upgrade requires a version of base-files incompatible with motd-news-config, which is also required for the update. I've also tried searching around for unable to create '/usr/bin/locale-check.dpkg-new' which could be the actual source of the errors, but I could not find any information on it. Any help, please?

Update: List of PPAs from grep ^ /etc/apt/sources.list /etc/apt/sources.list.d/*:

deb http://mirrors.digitalocean.com/ubuntu/ bionic main restricted
deb http://mirrors.digitalocean.com/ubuntu/ bionic-updates main restricted
deb http://mirrors.digitalocean.com/ubuntu/ bionic universe
deb http://mirrors.digitalocean.com/ubuntu/ bionic-updates universe
deb http://mirrors.digitalocean.com/ubuntu/ bionic multiverse
deb http://mirrors.digitalocean.com/ubuntu/ bionic-updates multiverse
deb http://mirrors.digitalocean.com/ubuntu/ bionic-backports main restricted universe multiverse
deb http://security.ubuntu.com/ubuntu bionic-security main restricted
deb http://security.ubuntu.com/ubuntu bionic-security universe
deb http://security.ubuntu.com/ubuntu bionic-security multiverse
8
  • Do you have some PPA that is involved with the motd program?
    – David
    Commented Apr 23, 2021 at 10:54
  • The specific error is Operation not permitted, which is different than a version conflict. There are many possible causes: Disk full, forgot to use sudo, changed ownership of that file, etc.
    – user535733
    Commented Apr 23, 2021 at 11:11
  • @David No, I haven't added any PPAs myself. Commented Apr 23, 2021 at 11:42
  • Sounds ominous who might have?
    – David
    Commented Apr 23, 2021 at 11:43
  • @user535733 I have several GB disk space remaining and am using sudo. The /usr/bin folder is owned by root. I've tried it with both root and non-root sudo users. Commented Apr 23, 2021 at 11:45

1 Answer 1

0

The solution that actually worked for me was to do force install:

sudo dpkg -i --force-all /var/cache/apt/archives/base-files_10.1ubuntu2.2_amd64.deb

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .