2

I have Ubuntu 20.04 + Cinnamon 4.

When I type an accentuated characters (`, ^) it is not immediately printed, instead, it waits for a second keystroke so that ` + e = è.

The problem is that of stack site, I have to type two ` or `+space to make inline code.

How could I display ` on the first keystroke?

My system is in french, and I use an AZERTY keyboard (so ` is altgr+7)

8
  • are you using an AZERTY or QWERTY keyboard and what have you set up in Settings > Language and Region? Please edit your question, not add to the comment trail. It would seem that the first keypress is "latching" which is how I use FR accents on a UK keyboard with the compose key. – 24601 Apr 22 at 9:16
  • There is no version of Ubuntu 20.4 there is a version 20.04 – David Apr 22 at 9:17
  • 1
    How could I display ` on the first keystroke? You don't, unless you want to break the ability to write accentuated characters like you need everyday for French. What you're "complaining" about is the "dead keys" feature that is required for typing in any language that frequently needs those characters (French happens to be one of the languages that need it the most). – ChanganAuto Apr 22 at 9:35
  • 2
    You can, however, add a second keyboard layout without "dead keys" and toggle to that one when you need and toggle back to the original for normal text. – ChanganAuto Apr 22 at 9:36
  • 1
    News to me, I don't use AZERTY :) Well, you already know what to do, what are your options and consequences... – ChanganAuto Apr 22 at 9:59
3

The problem was that I had the wrong layout. (Settings -> Keyboard -> layout) I changed it from "Français (variante obsolète)" to "Français". In this new layout, ^ is a dead key but ` is not which solves the problem

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.