20

I recently switched from Windows 10 to Ubuntu. So far so good, but I get these errors on every boot. I was not getting these when on Windows 10 (not sure if it is because Windows didn't have these errors or Windows just hided them from me) I just ignored them since the system can still boot and I think these are not fatal errors.

But now I actually want to know if I should take action, or this can be safely ignored (i.e does not do any harm), or should I add noacpi or something? I read that might also stop other working acpi thingies from working so I just ignored until this day I decided to ask here.

The reason I actually want to know this can be solved without any harm is, well, it is annoying to see these every boot and they seem to delay boot a bit (not sure if it is because of it though, but it hangs for like 1.5-2 seconds waiting on blinking _ after the error before going to ubuntu).

The errors are these:

ACPI Error: Aborting method \_PR.CPU0._PDC due to previous error (AE_NOT_FOUND) (20201113/psparse-529)

ACPI BIOS Error (bug): Could not resolve symbol [\_PR.CPU0._PPC], AE_NOT_FOUND (20201113/psargs-330)

I don't know what PR or PPC means but from the CPU0 part, it seems like something related to my CPU's first core (I have a dual core one) but my CPU is working fine (and was working fine in Windows too)

2 Answers 2

28

Some BIOS/UEFI developers are just lazy and don't implement the entire ACPI specification into their BIOS/UEFI, or more worse, they implement it in the wrong way. When Linux tries to read some specific ACPI parameters, which don't exist, or are wrong, it fails and reports this kind of error.

You may try a BIOS/UEFI update, but in most times you may just ignore these kind of "errors" and treat them more like a warning.

An example:

Mainboard-manufacturer XYZ creates 2 similar mainboards, but one has an additional Ethernet adapter:

  1. Mainboard-manufacturer XYZ creates a BIOS/UEFI for the mainboard with the additional Ethernet adapter and installs it on the mainboard with the additional Ethernet adapter.
  2. Mainboard-manufacturer XYZ is lazy and uses the same BIOS/UEFI image for the mainboard without the additional Ethernet adapter.

Some user named Mustafa Öncel installs Linux on a mainboard of XYZ which hasn't the additional Ethernet adapter. Linux kernel reads the ACPI-table of the BIOS/UEFI, this table says there is an additional Ethernet adapter, Linux tries to read the memory area, but fails, because there is no additional Ethernet adapter.

Note: If this error didn't occurred in the past, but now it does, it may be because you use a new Linux kernel, you changed your BIOS/UEFI or your hardware fails. Also, not receiving the ACPI error message doesn't guarantee that there is no error, it only guarantees that the Linux kernel is unable to detect an error. That's why you'll often see this type of error when updating to a newer kernel, cause the newer kernel is able to detect this error, while the older kernel wasn't able to detect the error.

How to fix: These suggestions aren't guaranteed to work, but they might work:

  • try BIOS/UEFI update and use default settings, if applicable
  • switch to the latest stable Linux kernel, if applicable
  • determine which hardware might be affected and check for malfunctions
  • contact computer/mainboard manufacturer and ask for support
  • in serious cases (system crashes) replace motherboard with another model
7
  • 1
    I have error "ACPI Error: AE_NOT_FOUND, While resolving a named reference package element - _PR_.P006 (20220331/dspkginit-438)" on my HP Omen 15 2020 I have both 2 laptops got the exact same error with different bios version. Does this error relate to power consume when on Battery seems Ubuntu take a lot of power than on Windows 11, usually on Windows can last about 5 hours scrolling and browsing stuffs, yet on Linux is seemed about less than 3 hours. Commented Mar 12, 2023 at 2:44
  • I think this answer could then suggest an action to mitigate the problem, like updating the BIOS/UEFI from the official producer instructions to latest version Commented Mar 15, 2023 at 6:17
  • @ValerioBozz but that will not fix this
    – Rinzwind
    Commented Apr 25, 2023 at 15:03
  • 3
    @Rinzwind you are wrong, a BIOS/UEFI update might resolve the problem.
    – paladin
    Commented Jul 17, 2023 at 13:30
  • @paladin nope. You'd need a new kernel too.
    – Rinzwind
    Commented Jul 17, 2023 at 15:20
1

I have 22.04 with 5.15.38 on a Lenovo machine. This just happened to me today, and the only solution that helped was switching BIOS graphics from Dynamic to Discrete. Not sure why.

1
  • 1
    many thanks for this answer, I was exactly in the same issue, tried with noacpi (causes touchpad t fail), acpi=off (causes only 1 processor to show/work) . I am on Ubuntu 22.04 freshly installed dual boot, saved my hours
    – 89n3ur0n
    Commented Aug 29, 2023 at 11:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .