My computer was acting really strange; the windows were flickering and parts of windows of different applications were partly appearing at random places. Also when I was typing, my computer seemed to automatically selected text and copied it, but it could also be that it just duplicated a part of the screen of a few seconds ago. Hard to describe, but unworkable.

My Thinkpad carbon passed all hardware tests and I installed a fresh Ubuntu install. Still the same behavior. I found a solution that I wanted to share.

  • This question has also been asked here.
    – Ricoter
    Apr 22, 2021 at 13:04

2 Answers 2


The -49 and -50 kernels are flawed, and have been withdrawn. There are graphics issues (possibly only with internal Intel video subsystems).

Boot your computer. At the GRUB menu, select the 2nd choice, Advanced Options (or some such), and select your -48 kernel, or earlier if you don't have -48, and run off of that for now.

Keep up to date with Software Updater and once you see the -51 kernel, or later, then choose it at next boot.

Update #1:

Start Synaptic and install these files (search for 5.8.0-48)...

enter image description here


ls -al /boot

Confirm that initrd.img-5.8.0-48-generic is there.

If it's not there, then run:

sudo update-initramfs -c -k 5.8.0-48-generic


sudo update-grub

At the GRUB menu, select Advanced Options, then select the -48 kernel to boot from.

  • To install 5.8.0-48, I've typed out the info from your image for CLI oriented people: sudo apt install linux-headers-5.8.0-48 linux-headers-5.8.0-48 linux-image-5.8.0-48-generic linux-modules-5.8.0-48-generic linux-modules-extra-5.8.0-48-generic
    – Ruben
    May 3, 2021 at 17:21
  • 1
    @Ruben Did you do the rest of the commands? Are you now able to boot -48? You should probably answer via your original question.
    – heynnema
    May 3, 2021 at 17:27
  • Yes, it worked, thank you! I've updated my original question to link to this answer.
    – Ruben
    May 3, 2021 at 17:29
  • 1
    @Ruben Good! Did you remember to up-vote this answer for me :-)
    – heynnema
    May 3, 2021 at 17:30


However I found a very simple solution that I didn't find here so I want to share it. I needed to reconfigure my window manager. It are the first two steps of this link

1.) Check the current running display manager by running command: systemctl status display-manager.service image

  1. Run command to reconfigure the default manager: sudo dpkg-reconfigure gdm3

Where you replace gdm3 with the manager you have at Main PID:

  • 1
    This doesn't sound right. The real problem is with kernel -49 and -50.
    – heynnema
    Apr 21, 2021 at 22:02
  • What doesnt sound right? It works perfectly again
    – Ricoter
    Apr 21, 2021 at 22:06
  • 1
    In terminal, do ls -al /boot, and see if -48 is there. You may only see -49 and/or -50.
    – heynnema
    Apr 21, 2021 at 22:23
  • 1
    If you're running ok now, no need to do anything, but if the problem returns, you'll have to do Update #1 to reinstall -48 and then boot to it... until they come out with a fixed kernel, which may be -51 or greater.
    – heynnema
    Apr 21, 2021 at 22:27
  • 1
    Please do keep me posted. Start future comments to me with @heynnema or I'll miss them.
    – heynnema
    Apr 21, 2021 at 22:55

Not the answer you're looking for? Browse other questions tagged or ask your own question.