0

I have an issue using my nvidia gpu with python tensorflow-gpu in ubunti 20.04 it is not detected. Please help me do some diagnostics if you have some idea

In windows this works fine. What I tried :

  • Changin hybrid to discrete settings makes ubuntu not having any display.
  • I tried changind the versions of gpu proprietart drivers available but without luck (tried all without restarting and only 460 and 450 with restarting i wil ltry the rest and report here)

Disclaimer the nvidia card originally cause d me to be unable to use my external monitort this can be solved using the open source drivers: Not detected second screen after update, Quadro RTX 3000 Mobile , Lenovo hinkpad p15 g1, Ubuntu 20.04

4
  • Have you disabled Secure Boot? Apr 18 at 6:30
  • Hello and thank you for the comment, is it influencing you think?
    – partizanos
    Apr 18 at 7:52
  • I didn't disable it, I only played modifying discrete and hybrid graphics.
    – partizanos
    Apr 18 at 7:55
  • Secure Boot prevents loading unsigned drivers like the ones from Nvidia, that's the problem. Apr 18 at 12:04
1

The problem, as usual, is having Secure Boot enabled in UEFI and unsigned drivers (Nvidia's).

Either disable Secure Boot in UEFI (easy) or use mokutil to enable "trust" for the Nvidia's driver modules (not easy).

2
  • Thanks will give a try
    – partizanos
    Apr 18 at 12:15
  • It worked thank you so much!
    – partizanos
    Apr 18 at 13:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.