2

Whenever I try to install wine64, it tells me to remove important packages and I don't know how to solve this.

Installing wine64 results with the procedure below:

$ sudo apt install wine64
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  apache2-data apache2-utils ethtool git-man gparted-common hwloc ieee-data liba52-0.7.4 libapr1 libaprutil1 libaprutil1-dbd-sqlite3
  libaprutil1-ldap libass9 libbs2b0 libcdio19 libdazzle-1.0-0 libdvdread8 libegl1-mesa liberror-perl libfftw3-double3 libflite1
  libgtkglext1 liblilv-0-0 liblinear4 liblua5.2-0 libmpeg2-4 libmysofa1 libnorm1 libopencore-amrnb0 libopencore-amrwb0 libpango-perl
  libpangox-1.0-0 libpcre16-3 libpcre32-3 libpgm-5.2-0 libpostproc55 librubberband2 libsepol1-dev libserd-0-0 libsidplay1v5
  libsord-0-0 libsratom-0-0 libvidstab1.1 libwxbase3.0-0v5 libx264-160 libxcb-xtest0 libzmq5 lua-lpeg ndiff nmap-common python-cairo
  python-gobject-2 python-pysqlite2 python-wxversion python3-bs4 python3-debconf python3-html5lib python3-lxml python3-soupsieve
  python3-webencodings
Use 'sudo apt autoremove' to remove them.
The following additional packages will be installed:
  libapt-pkg6.0 libpci3 pciutils python3-distupgrade ubuntu-release-upgrader-core wine
Suggested packages:
  q4wine winbind winetricks playonlinux wine-binfmt dosbox exe-thumbnailer | kio-extras wine64-preloader
Recommended packages:
  apt wine32
The following packages will be REMOVED:
  aircrack-ng anydesk apache2 apache2-bin apt apt-utils code git gnome-calendar gparted gstreamer1.0-libav gstreamer1.0-plugins-ugly
  libavfilter7 libblkid-dev libffi-dev libfprint-2-tod1 libglib2.0-dev libglib2.0-dev-bin libgtk2-perl libllvm9 libmount-dev
  libpcre2-dev libpcre2-posix2 libpcre3-dev libpcrecpp0v5 libselinux1-dev libwxgtk3.0-gtk3-0v5 net-tools nmap python-gtk2
  python-wxgtk3.0 ubuntu-desktop ubuntu-desktop-minimal ubuntu-minimal ubuntu-release-upgrader-gtk update-manager update-notifier
  update-notifier-common uuid-dev vino zenmap zoom
The following NEW packages will be installed:
  wine wine64
The following packages will be upgraded:
  libapt-pkg6.0 libpci3 pciutils python3-distupgrade ubuntu-release-upgrader-core
WARNING: The following essential packages will be removed.
This should NOT be done unless you know exactly what you are doing!
  apt
5 upgraded, 2 newly installed, 42 to remove and 37 not upgraded.
Need to get 1,311 kB of archives.
After this operation, 700 MB disk space will be freed.
You are about to do something potentially harmful.
To continue type in the phrase 'Yes, do as I say!'
 ?]

Performing sudo apt update && upgrade results with:

Hit:1 http://downloads.metasploit.com/data/releases/metasploit-framework/apt lucid InRelease
Hit:2 http://in.archive.ubuntu.com/ubuntu focal InRelease                                                                             
Hit:3 http://in.archive.ubuntu.com/ubuntu focal-updates InRelease                                                                     
Hit:4 http://in.archive.ubuntu.com/ubuntu focal-backports InRelease                                                                   
Hit:5 http://ppa.launchpad.net/gezakovacs/ppa/ubuntu focal InRelease                                                                  
Hit:6 http://security.ubuntu.com/ubuntu focal-security InRelease                                 
Hit:7 http://dl.google.com/linux/chrome/deb stable InRelease
Reading package lists... Done
Building dependency tree       
Reading state information... Done
All packages are up to date.
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

Wine installation:

$ sudo apt install wine                                 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Suggested packages:
  q4wine winbind winetricks playonlinux wine-binfmt dosbox exe-thumbnailer | kio-extras
The following NEW packages will be installed:
  wine
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 51.9 kB of archives.
After this operation, 197 kB of additional disk space will be used.
Get:1 http://in.archive.ubuntu.com/ubuntu focal/universe amd64 wine all 5.0-3ubuntu1 [51.9 kB]
Fetched 51.9 kB in 0s (348 kB/s)
Selecting previously unselected package wine.
(Reading database ... 276005 files and directories currently installed.)
Preparing to unpack .../wine_5.0-3ubuntu1_all.deb ...
Unpacking wine (5.0-3ubuntu1) ...
Setting up wine (5.0-3ubuntu1) ...
Processing triggers for man-db (2.9.1-1) ...
Processing triggers for hicolor-icon-theme (0.17-2) ...
Processing triggers for wine (5.0-3ubuntu1) ...

wine
it looks like wine32 is missing, you should install it.
as root, please execute "apt-get install wine32"
Usage: wine PROGRAM [ARGUMENTS...]   Run the specified program
       wine --help                   Display this help and exit
       wine --version                Output version information and exit

After this error, I was also trying to install wine32 which resulted with a dependency error:

$ sudo apt install wine32                                                                                                        
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 wine32:i386 : Depends: libwine:i386 (= 5.0-3ubuntu1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Then, when I try to install libwine:i386 in order to solve the dependency problem, I receive this broken package problem:

$ sudo apt install libwine:i386                                                                                                
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libwine:i386 : Depends: libfontconfig1:i386 (>= 2.12.6) but it is not going to be installed
                Depends: libfaudio0:i386 (>= 19.06.07) but it is not going to be installed
                Depends: libglib2.0-0:i386 (>= 2.12.0) but it is not going to be installed
                Depends: libgphoto2-6:i386 (>= 2.5.10) but it is not going to be installed
                Depends: libgstreamer-plugins-base1.0-0:i386 (>= 1.0.0) but it is not going to be installed
                Depends: libgstreamer1.0-0:i386 (>= 1.4.0) but it is not going to be installed
                Depends: libldap-2.4-2:i386 (>= 2.4.7) but it is not going to be installed
                Depends: libx11-6:i386 but it is not going to be installed
                Depends: libxext6:i386 but it is not going to be installed
                Recommends: libcups2:i386 (>= 1.4.0) but it is not going to be installed
                Recommends: libgl1:i386 but it is not going to be installed
                Recommends: libglu1-mesa:i386 but it is not going to be installed or
                            libglu1:i386
                Recommends: libgnutls30:i386 (>= 3.6.5) but it is not going to be installed
                Recommends: libosmesa6:i386 (>= 10.2~) but it is not going to be installed
                Recommends: libsane:i386 (>= 1.0.24) but it is not going to be installed
                Recommends: libsdl2-2.0-0:i386 (>= 2.0.10) but it is not going to be installed
                Recommends: libxcomposite1:i386 (>= 1:0.4.5) but it is not going to be installed
                Recommends: libxcursor1:i386 (> 1.1.2) but it is not going to be installed
                Recommends: libxfixes3:i386 but it is not going to be installed
                Recommends: libxi6:i386 but it is not going to be installed
                Recommends: libxinerama1:i386 but it is not going to be installed
                Recommends: libxrandr2:i386 but it is not going to be installed
                Recommends: libxrender1:i386 but it is not going to be installed
                Recommends: libxxf86vm1:i386 but it is not going to be installed
                Recommends: libgl1-mesa-dri:i386 but it is not going to be installed
                Recommends: gstreamer1.0-plugins-good:i386 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

I also tried other tutorials to install winehq-stable but it say it has unmet dependencies.

$ sudo apt install --install-recommends winehq-stable
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 winehq-stable : Depends: wine-stable (= 6.0.0~focal-1)

E: Unable to correct problems, you have held broken packages

I did aptitude also it recommended to leave wine32 packages as it is. So it is not doing anything if the solution is approved. What should I do?

3
2

I would say you should first do:

sudo apt update
sudo apt upgrade -y
sudo apt dist-upgrade -y
sudo apt install wine
6
  • I tried it its now saying that it has unmet dependencies – yashas kr Apr 18 at 21:22
  • @yashaskr can you post the output of sudo apt update && sudo apt upgrade? – lucki1000 Apr 19 at 15:36
  • your solutions worked for wine64 but wine32 is not working pls help Thanks! – yashas kr Apr 20 at 4:22
  • @yashaskr Have you tried the official wineHQ installation guide? Overall, if your system did not have any prior apt or dpkg errors when installing new packages, installing winehq-stable should result with no problems and usually only needs this installation command: sudo apt install --install-recommends winehq-stable. – Pizza Apr 20 at 4:51
  • I followed all the steps in website but its not working... Its say it has unmet dependencies... – yashas kr Apr 21 at 4:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.