My workstation with Ubuntu 12.04 is a MacBook Pro which supports a Multitouch Trackpad.

Unfortunately, I'm constantly accidentally triggering the three finger touch gesture to resize a window:

enter image description here

How can I disable this gesture?


Install Compiz config manager:

sudo apt-get install compizconfig-settings-manager

then run compiz config manager (ccsm in terminal) or simply type ccsm in dash.

and find at the bottom of plugins list:

Unity MT Grab Handles to disable it.

| improve this answer | |
  • 3
    For me, this only removes the move-symbols (the transparent circles with arrows on gentmatt's screenshot above). The three finger touch gesture still moves/resizes the windows, but without showing those symbols. – Alfred Godoy Jun 3 '12 at 18:44
  • 4
    I can confirm that this does not disable 3 finger gestures. I have MT Grab Handles disabled and I am still able to 3 finger drag windows around the screen. I would really like to disable this functionality. Any helpful contributions would be greatly appreciated. – oznah Jun 10 '12 at 3:11
  • This is not the "answer" at all. The question asked was how to disable multi-touch gestures. – doug65536 Dec 25 '15 at 21:33

I have solved this issue by setting the following configuration values (initial values were 0):

synclient ClickFinger3=2
synclient TapButton3=2
| improve this answer | |
  • That did the trick. I found a couple more helpful links. I made changes in my xorg.conf and things are good now. askubuntu or arch – oznah Oct 10 '12 at 18:46
  • 1
    why isn't there a UI for synclient? srsly (ubuntu 12.10) – NullVoxPopuli Dec 12 '12 at 16:14
  • 1
    @TheLindyHop nobody has written one yet, get on it! – CloudMeta Feb 21 '13 at 23:41
  • 1
    These reenable the middle-click-paste. Suggest value that is "ridiculous" like 12 or more for both parameters to disable the tripple-tap completely – ddotsenko Apr 21 '14 at 4:37
  • I used 15 for each of the values and it worked great on 14.04. – mrm Mar 3 '15 at 16:38

The trackpad is configured by default to ignore three-finger taps (and three-finger clicks), and can be set it to regain control of it, thus overriding the window move association to three-finger taps. This is how it can be done:

  1. Look for the relevant property - open a terminal and type in:


    Locate the line containing the trackpad details (e.g. ↳ CyPS/2 Cypress Trackpad id=12 [slave pointer (2)] ), and note its id value. Now type in:

    xinput list-props [id]

    where [id] is replaced by the id value (which is 12 in the given example). Now locate the Synaptics Tap Action property (e.g. Synaptics Tap Action (282): 2, 3, 0, 0, 1, 3, 0) and note its number, it will be enclosed inside round brackets (here it's 282). Also note the property values, we will use them later.

  2. Assuming you want this behavior at startup, create a shell script and add it to the startup programs. Let's call this script trackpad.sh. Our goal is to replace the last value with a new one, e.g. for middle click. Edit the script to contain the following:

    xinput set-prop [xinput-prop-id] [prop-number] [TR] [BR] [TL] [BL] [F1] [F2] 2

    Our concrete example command will than look like this (just for the sake of demonstration):

    xinput set-prop 12 282 2, 3, 0, 0, 1, 3, 2

    Notice that we replaced only the last value from 0 to 2, to signify middle click. You can choose any between 1 (left click), 2 (middle click), or 3 (right click).

  3. Grant the script with execution permissions, and run it. You're good to go!


| improve this answer | |

The solutions above did not work on my OS, Ubuntu 16.04, and I have a Dell Precision. TapButton3 and ClickFinger3 did not have any affect. I still had an annoying application switcher come up and change my application when I would accidentally touch thee fingers to the touchpad, which happened all the time. I really hated this feature and I finally figured out how to truly disable it.

What I noticed was that on the list of xinput devices was two touchpads. This will interfere with synclient settings, you cannot just change TapButton3 and ClickFinger3 when you have multiple touchpads, you need to use xinput.

For xinput this is the command you need,

xinput list-props

⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ DLL07BF:01 06CB:7A13 Touchpad             id=12   [slave  pointer  (2)]
⎜   ↳ SynPS/2 Synaptics TouchPad                id=15   [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]
    ↳ Video Bus                                 id=8    [slave  keyboard (3)]
    ↳ Power Button                              id=9    [slave  keyboard (3)]
    ↳ Sleep Button                              id=10   [slave  keyboard (3)]
    ↳ Integrated_Webcam_HD                      id=11   [slave  keyboard (3)]
    ↳ Intel HID events                          id=13   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=14   [slave  keyboard (3)]
    ↳ Dell WMI hotkeys                          id=16   [slave  keyboard (3)]

Find your device from this list.

xinput set-prop <device ID>|<device name> <Synaptics Tap Action>|<number (on my machine this is 282)>  LAST VALUE 2

xinput set-prop <device ID>|<device name> <Synaptics Click Action>|<number (on my machine this is 283)> LAST VALUE 2

Those are usually lists of numbers set them like 1 3 2.

Setting to 2 (or greater, like 10!) will change the type of click three fingers do, if you do not want to map three fingers to any type of click use something outside of the range 1-3. Personally I used 10, now nothing happens with three finger taps.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy