16

i have installed nagios and i want to install nrpe. While installing NRPE, when i execute (/home/abc/nrpe/configure)

./configure

it stops after reaching the following line

...

checking for type of socket size... size_t
checking for SSL headers... SSL headers found in /usr
checking for SSL libraries... configure: error: Cannot find ssl libraries

I have installed libssl-dev and openssl package as i found them as a solution for this error.

I tried the following option also

./configure --with-ssl=/usr/bin/openssl --with-ssl-lib=/usr/lib

But the error remains.

What can be the possible solution for this ? I am using ubuntu 12.04 as my operating system. Thanks in advance.

23

this worked for me:

./configure --with-ssl=/usr/bin/openssl --with-ssl-lib=/usr/lib/x86_64-linux-gnu

I found the dir through:

apt-file search libssl | grep libssl-dev
4
  • 1
    Thanks for reply. I end up with the installation of the older version of nrpe and that worked for me. – Ankur Trapasiya May 11 '12 at 19:54
  • This worked! Thanks. For future reference, in what docs did you find those configure --with options? – WAF Feb 18 '15 at 12:56
  • 1
    I had to combine this with another answer, and install libssl-dev first. sudo apt-get install libssl-dev – IBam Feb 17 '16 at 11:02
  • If you run it from a Raspberry with ubuntu, it should be ./configure --with-ssl=/usr/bin/openssl --with-ssl-lib=/usr/lib/aarch64-linux-gnu – Carol Feb 1 '20 at 4:25
8

Use the following command to fix it:

yum install openssl-devel

1
  • 1
    Yum is not used in ubuntu. Should be sudo apt-get install openssl-devel – Evenbit GmbH Dec 4 '13 at 9:07
8

I had similar issues on a Raspberry PI, after I'd installed the libssl-dev package

sudo apt-get install libssl-dev

but managed to find the ssl lib for the configure command with this:

# dpkg -L libssl-dev

.
.
.
/usr/lib/arm-linux-gnueabihf
/usr/lib/arm-linux-gnueabihf/libssl.a
/usr/lib/arm-linux-gnueabihf/pkgconfig
/usr/lib/arm-linux-gnueabihf/pkgconfig/libcrypto.pc
/usr/lib/arm-linux-gnueabihf/pkgconfig/libssl.pc
/usr/lib/arm-linux-gnueabihf/pkgconfig/openssl.pc
/usr/lib/arm-linux-gnueabihf/libcrypto.a
/usr/lib/arm-linux-gnueabihf/libssl.so
/usr/lib/arm-linux-gnueabihf/libcrypto.so

# ./configure --with-ssl=/usr/bin/openssl --with-ssl-lib=/usr/lib/arm-linux-gnueabihf
5

With Ubuntu Server, try this:

sudo apt-get install libssl-dev

Not the answer you're looking for? Browse other questions tagged or ask your own question.