Recently updated to 12.04 (64-bit) on my AMD hex-core 4GB system, over the last few days I feel that the overall system is sluggish/laggy, for instance hitting the dash button, the dash opens but the recent activity of files/videos etc is incredibly slow to populate, like wise in Nautilus and browsing my media, the file names are showing up but it takes an age to populate the "thumb" of the video, If I go into Gnome-shell the shell response is a little faster but again clicking on applications there is still a noticeable pause.

I have the latest Nvidia drivers loaded and I have very fast SATA drives, if I reboot into windows 7 the system is so much quicker in its response, I only use windows for games and Ubuntu is my main OS.

10.04/10.10/11.04 was super quick and this was when the system still had a dual-core Chip and a worse Nvidia card, 11.10 was pretty snappy, but 12.04 just feels bloated on each system I have installed it on. My hardware is more than up to the task so has anyone got any commands i can run to help diagnose the issue?

Anyone else got the same problems?

  • 2
    I am suffering from this problem for three to four days.
    – beeju
    May 7, 2012 at 12:35
  • Just another +1. Especially evident in nautilus where it can take several seconds to show contents of a folder, even if it just contains a few files... Moving the cursor between items in nautilus using arrow keys is also extremely laggy -- when tapping the arrow keys quickly I can follow the cursor moving in slow motion between items... In addition, doing basically anything in nautilus makes it consume more than 100% cpu (on a mutli-core system).
    – Nicke
    May 7, 2012 at 14:07
  • The curious thing is I have the 32 bit version running both on a quad core desktop and a little netbook. Both seem faster than they were on 11.10. Both were clean installs but the one on the desktop has been used and upgraded since Alpha 1.
    – barrydrake
    May 7, 2012 at 14:51
  • Hi guys i have been playing about today with my system, I have found that Ubuntu One would be using 120% CPU the first 5 mins after boot - I have ensured that this is now not syncing by default, but it still starts on boot. I have also set the Swappness to 10 from the default of 60, also I have switched off "sync to vblank" in compiz which has sped up the graphics and in the Nvidia control panel set it to max performance all the time. The other thing I have done is changed Nautilus settings to not show thumbs or txt from a txt doc - Seems to have made a vast boost. Still not 100% though. :(
    – Murphy1138
    May 7, 2012 at 17:49
  • Also I have loaded "preload" this over time works out what you use most and has it preloaded , so when you launch Chrome for example it fires up quicker. sudo apt-get install preload
    – Murphy1138
    May 7, 2012 at 17:53

6 Answers 6


I had similar issue after upgrading my 10.04 to a 12.04 when running in gnome-classic (didn't get time to experience gnome-shell or unity yet)

  • laptop with i7 cpu, 8G of ram, nvidia 880M, so a pretty good configuration
  • using compiz but most of effects are disabled (yet, the Expo plugin is a must for me)

  • normal windows operations are very slow, especially swapping from one window to another, or switching desktop

  • things gets even worse with the number of windows opened

I tested lot of things :

  • upgrading nvidia drivers to 304.43 thanks to the "xorg-edgers" PPA ==> Better results but finally it just need more time to get the same slow down.
  • disabling most "sync to vblank" ==> no particular improvements

Finally, I disabled the Compiz "Place windows" pluggins, and every things start to be fast again !

I didn't check more, but there are definitely something wrongs with Compiz and Gnome3.4. Hopefully, it looks like only restricted to some pluggins.

  • 1
    Thanks a bunch! "Place Windows" Did it for me also. 295.49 drivers.
    – EdH
    Sep 27, 2012 at 21:03
  • works also for 12.10
    – ts01
    Dec 3, 2012 at 15:36

Since today (at least for me). In the Ubuntu 32 bit and 64 bit version of 12.04, updating to the latest Nvidia 295.49 fixed all lag problems.

enter image description here

Confirmed on both 32/64 after restarting and toying around with several windows and wine apps. Everything feels correct again.

Here is the launchpad information about it.

But I can add to it that it should also include the 9500 GT, 220 GT and 440 GT. All of them were also suffering from the same problem but now is gone.

Problems like the following which I was having are gone:

  • Moving the mouse in any window
  • Moving a Window
  • Opening a folder in Nautilus (Or even going back to a previous folder)
  • Wine Games
  • Ubuntu Games
  • Slow LibreOffice, Banshee or Rhythmbox
  • Weird artifacts when starting Ubuntu (Including missing panels or loading without them)
  • The update to 295.49 seems to have fixed the problem for me! Thanks!
    – Nicke
    May 9, 2012 at 11:23
  • This is "proposed" right now? How long before something like this is released into the main repository?
    – Brian Neal
    May 12, 2012 at 1:20
  • Totally depends on the testing phase to change it from proposed to main. Although I have never had a problem activating all the repos. May 12, 2012 at 1:22

I had the same issue, Nautilus being extremely slow.

I solved the problem by opening "additional drivers" and activating the "current version - reccomended" Nvidia driver.


I have an acer aspire one, only changed the value of swappiness to 10 and nautilus is fast again. I guess it tells the kernel, "dont aggressively move stuff to swap from physical RAM". It was a huge improvement. Original value of swappiness was 60.

sudo sysctl vm.swappiness=10

For temporally change to 10.

Source: http://modifyubuntu.com/#swap


If none of the above comments, answer(s) help -

What I've found here, (nvidia) is that at log in all is pretty good. But sooner or later things get stuffed up & slow. Opening, closing, min & restoring windos, switching WS's, smooth scrolling, ect. ect.

At least here disabling the animations plugin in compiz clears it all up. Some I'm not going to use it, would rather have snappy performance then some effect of no real value


Which nvidia drivers are you running? (open "NVIDIA X Server Settings", look for NVIDIA Driver Version under X Server Information).

version 295.33 and 295.40 have a horrible performance regression that makes my ubuntu pretty much unusable because of the lag. I have a GeForce 210, quad-core i5, intel SSD, and 8GB ram. System Monitor shows compiz using ~25% cpu constantly.

Installing 295.49 fixes the problem.

  • 295.40 is what I am running, I will update now and get back. Cheers chaps :)
    – Murphy1138
    May 8, 2012 at 21:01
  • Looks like the Driver update has made a massive performance boost.
    – Murphy1138
    May 10, 2012 at 11:01

Not the answer you're looking for? Browse other questions tagged or ask your own question.