A simple Microsoft Optical mouse 1000 (USB) that runs perfectly on Windows, freezes up under Ubuntu 10.x and Fedora 1x after about 10 minutes of using the OS.

Rebooting, the same problem comes up again in a few minutes.

Interestingly, the problem does not occur when Ubuntu is installed in Oracle VirtualBox VM. Installing Ubuntu "as usual" (i.e. not in a VM), causes the problem to occur.

Has any one here faced the same problem or have a solution for it? Maybe using a different mouse that is known to work with Ubuntu 10.x?

If it helps my system is: Asus P5NSLI motherboard (nVidia nForce 570 chipset), 4 GB RAM
Ubuntu 10.10 refers to "32 bit" version of Ubuntu

It seems that Ubuntu has a lot of all types of freeze issues.
Can someone recommend a version of Ubuntu that is fairly recent and stable ? I intend to use Ubuntu for Ruby on Rails development.


I had the same issue with USB in general, Its not the Mouse its Ubuntu. Personally I did not fix the issue since I upgraded my PC and reloaded 10.10, and no issues so far other then my user issues lol.

From what i gathered it was something to do with certain hardware support, in my case my Asus P4 board, very similar to yours. After about 10 mins or less of using it, mouse froze, but the PS/2 keyboard still worked, rebooting only fixed the issue temporarily. That issue had me plagued for months. Tried reloading Device managers, HAL, compiled kernels, and every thing that had to do with my mouse and no luck.

I wish I could give you more insight, but its the biggest reason I didn't upgrade from 9.04 to something more current till recently.

My only suggestion is to use an older version, either 10.04 or to another dist....

but if your really looking for a challenge, start with getting the logs and go from there (if your issue is the same Logs may not give any info)

  • I just gave up on using Ubuntu on a real machine. Using it on VirtualBox instead. Jeez, when will Ubuntu be ready for the real world! :D – Zabba Feb 14 '11 at 12:37
  • Good choice :) as for you side note, Ubuntu works great with Newer hardware, but for older PCs i would definitely choose another Dist, PClinux comes to mind, or VM it – jsolarski Feb 14 '11 at 13:14

Activate proposed updates and update your system. If that does not help, install Lucid kernel (2.6.32). And last oportunity for you - install and use Ubuntu 10.04 (Lucid), it's pretty stable.

EDIT: If Lucid is freezing also, try very last kernel from kernel PPA http://kernel.ubuntu.com/~kernel-ppa/mainline/v2.6.37-rc1-maverick/

  • Ubuntu 10.04 has the same problem, unfortunately. Can you specify the link to "proposed updates" ? – Zabba Nov 15 '10 at 6:42
  • I mean System-Administration-Software sources, and set all checkboxes on second (or third) tab. – Extender Nov 15 '10 at 6:56

I had this problem with similar Asus board. I update the BIOS and the problem's gone.

  • 1
    Welcome to AskUbuntu! I would write a bit more if possible, or post it as a comment, but I think you can't write comments yet. Also, think a bit more maybe (O God, that sounds terrible; no offense meant). Is really the BIOS? He said it worked under windows. – MadTux Jun 6 '13 at 15:04
  • How did you update the BIOS. Can you write it here. – Austin Sep 21 '18 at 11:38

Not the answer you're looking for? Browse other questions tagged or ask your own question.