0

Edits to clarify:

Will the amdgpu-pro driver work with an RX 460? I got it from the amd downloads for rx 460...

I was hoping to CPU + GPU render in Blender, but as of now it still says, "no compatible GPUs found for path tracing" in preferences. I was hoping an updated pro driver would fix this. Eevee runs fine, and even cycles but I was hoping to use both to render.

Either way, It seems like the open source driver is running still anyway.

System info: I'm using Blender 2.92.0 on Ubuntu 20.04.2 LTS. I have a budget system with an RX 460, and I just installed the most current amd proprietary drivers (20.50 release) (pro stack)

sudo lshw -c video 

outputs:

description: VGA compatible controller
       product: Baffin [Radeon RX 460/560D / Pro 450/455/460/555/555X/560/560X]
       vendor: Advanced Micro Devices, Inc. [AMD/ATI]
             ...
       capabilities: pm pciexpress msi vga_controller bus_master cap_list rom
       configuration: driver=amdgpu latency=0

i had already installed the amdgpu-pro driver with:

$ ./amdgpu-pro-install -y --opencl=pal,legacy

except that it then asked me to instead run

./amdgpu-pro-install -y --opencl=rocr

Which I did, and it says it was installed if i run it again.

So is it still using the open source driver? Should I have uninstalled that first? I mean of course I ran across plenty of other comments in similar scenarios ( with other gpus), but of course I don't want to start --purge this and --uninstall that several times over recklessly.

Thanks.

0

You have to do a little post-install in order to Blender see your GPU. Add your user to video and render groups.

sudo usermod -a -G video $USERNAME sudo usermod -a -G render $USERNAME

1
  • Hi, thanks for answering. To be honest, I dont know what you mean exactly. When I put that in the terminal, it just gave me a list of usage options for usermod, starting with: "Usage: usermod [options] LOGIN" , then all the command options for usermod.
    – gson78
    May 7 at 10:23
0

Okay it looks like the pro drivers were installed after all.

running:

dpkg -l amdgpu-pro

gets me this.

Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name           Version       Architecture Description
+++-==============-=============-============-==============================================
ii  amdgpu-pro     20.50-1234664 amd64        Meta package to install amdgpu Pro components.

I remember that was the number I installed. So then question is, why isn't Blender recognizing any openCL support?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.