0

ive been trying to setup my 20.04 ubuntu server and get it connected to the internet through wifi, ive been following this website https://linuxconfig.org/ubuntu-20-04-connect-to-wifi-from-command-line, and im to the point that there are no errors being returned when i use netplan apply, but im also not getting anything that says success either from what i can tell i have the formatting of the netplan file correct but just in case here is what ive got

network:
    ethernets:
        enp1s0:
            dhcp4: True
            optional: True
    version: 2
    wifis:
    wlo1:
            optional: true
            access-points:
                "access point name here":
                   password: "password here"
            dhcp4: true
0
1

Connect via Ethernet and install wpasupplicant and net-tools.

sudo apt update

sudo apt install wpasupplicant net-tools

Use this .yaml file... use the EXACT same spacing, indentation, and no tabs...

network:
  version: 2
  renderer: networkd
  ethernets:
    enp1s0:
      dhcp4: true
      optional: true
  wifis:
    wlo1:
      dhcp4: true
      access-points:
        "access point name here":
          password: "password here"

sudo netplan generate

sudo netplan apply

reboot

7
  • I think he also needs net-tools.
    – chili555
    Apr 14 at 20:17
  • @chili555 Added. Thanks!
    – heynnema
    Apr 14 at 20:28
  • thank you, ive been working at this for 3 days now, i appreciate the help Apr 14 at 21:43
  • 1
    @Trainz_driver If my answer helps to solve your problem, please remember to accept it by clicking on the checkmark icon that appears just to the left of my answer. Thanks!
    – heynnema
    Apr 14 at 21:49
  • i was wondering how to do that, thank you again for the help Apr 14 at 22:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.