I'm not sure what's caused it. I haven't changed any system settings. The only thing I've done that may have broken something is updating my software.

My update was:

upgrade linux-generic-hwe-20.04:amd64
upgrade linux-image-generic-hwe-20.04:amd64 
upgrade linux-headers-generic-hwe-20.04:amd64 
upgrade linux-image-extra-virtual:amd64
upgrade linux-image-generic:amd64
upgrade linux-libc-dev:amd64 5.4.0-70.78 5.4.0-71.79
upgrade libseccomp2:amd64 2.4.3-1ubuntu3.20.04.3 2.5.1-1ubuntu1~20.04.1
upgrade nomachine:amd64 7.3.2-3 7.4.1-3```

Removing nomachine did not solve the problem.

It was far worse before, I'm not sure how to describe exactly, but my entire screen's UI was glitching out. So I rebooted and that stopped, but now the terminal text looks like this:

glitched terminal text

I haven't changed any terminal settings. This seems to be occurring in the entire OS. Here is another example:

flickering dock

Not sure how to go about troubleshooting this? I don't have the time to reinstall the OS, nor do I think I should have to because this is just ridiculous and shouldn't happen. I'm not aware of anything I've done to make the system unstable.


Earlier I also tried booting the PC. It failed and got stuck on some command in a terminal (didn't manage to take a photo of what it said).

So I rebooted into recovery mode with both available kernels. I was getting strange glitches like this:

dialog text disordered, colours mixed up

That didn't work. So I rebooted the PC normally, and now I somehow logged in fine. Now I'm getting popups saying to report a system error. It says this:

report error with bluetoothd


  • Ubuntu 20.04.2 LTS
  • GNOME 3.36.8
sudo lshw -class display
       description: VGA compatible controller
       product: Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 06
       width: 64 bits
       clock: 33MHz
       capabilities: msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:33 memory:f7800000-f7bfffff memory:e0000000-efffffff ioport:f000(size=64) memory:c0000-dffff

I also did MemTest86, which passed with 0 errors.

Let me know if more details are required.


The -49 and -50 kernels are flawed, and have been withdrawn. There are graphics issues (possibly only with internal Intel video subsystems).

Boot your computer. At the GRUB menu, select the 2nd choice, Advanced Options (or some such), and select your -48 kernel, or earlier if you don't have -48, and run off of that for now.

Keep up to date with Software Updater and once you see the -51 kernel, or later, then select it at next boot.

Update #1 (for @dspacejs):

Start Synaptic and install these files (search for 5.8.0-48)...

enter image description here


ls -al /boot

Confirm that initrd.img-5.8.0-48-generic is there.

If it's not there, then run:

sudo update-initramfs -c -k 5.8.0-48-generic


sudo update-grub

At the GRUB menu, select Advanced Options, then select the -48 kernel to boot from.

  • Yesterday my OS/laptop began having serious issues(wifi,bluetooth,sound,ethernet and etc not working), and in last I found out it has happened by the -49 kernel, so, Just reported the bug and I'm , using -48 from grub menu from then – The Dark_Command Apr 17 at 15:24
  • running with 50 version now without problem, but problem can arriva later changin refresh rate as discovered in reddit.com/r/Fedora/comments/9983xl/… – Luigi Pirelli Apr 18 at 6:43
  • I'm having the issue in 5.8.0-59-generic – isapir Jun 27 at 22:02
  • @isapir Please start a new question. – heynnema Jun 27 at 22:12

I was having the same issue as of late June 2021 with Kernel version 5.8.0-59-generic. Since the issue has been around for 10 updates now it looks like it isn't given a high priority, so I switched from Xorg to Wayland which doesn't suffer from that issue.

To do that, while logged out, select the username, click the settings cog on the bottom right and choose "Ubuntu on Wayland" instead of "Ubuntu". Then log in.

If you don't have that option then edit /etc/gdm3/custom.conf and make sure that the line WaylandEnable=false is commented out (changes to that file require sudo systemctl restart gdm3 to be applied)


Same issue experienced, see also Highlight Diagonal Tears with Intel Graphics (Ubuntu 20.04)

I reverted to the 5.4 kernel revision which has rectified the issue

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.