14

I am seeing below error message on my laptop screen upon loading Ubuntu but I am able to login without problem. What do you think could be wrong?

DMAR: [Firmware Bug]: No firmware reserved region can cover this RMRR [0x000000008d800000-0x000000008fffffff], contact BIOS vendor for fixes
DMAR: [Firmware Bug]: Your BIOS is broken; bad RMRR [0x000000008d800000-0x000000008fffffff]

I've found more details on kernel log:

BIOS vendor: INSYDE Corp.; Ver: 5.00; Product Version: PSLZAE-00R00STE
DMAR-IR: IOAPIC id 2 under DRHD base  0xfed91000 IOMMU 1 
DMAR-IR: HPET id 0 under DRHD base 0xfed91000
DMAR-IR: x2apic is disabled because BIOS sets x2apic opt out bit.
DMAR-IR: Use 'intremap=no_x2apic_optout' to override the BIOS setting.
DMAR-IR: Enabled IRQ remapping in xapic mode
x2apic: IRQ remapping doesn't support X2APIC mode
4
  • 1
    What the message says. Contact the computer maker.
    – David DE
    Commented Apr 13, 2021 at 8:17
  • Never seen this before, you definitely need to contact whoever manufactured your machine.
    – Vasilisa
    Commented Apr 13, 2021 at 8:19
  • 1
    From the Dell site dell.com/community/Linux-Developer-Systems/…
    – David DE
    Commented Apr 13, 2021 at 8:20
  • There is nothing to do to fix this error as I understand. Let me send this to Toshiba then. Commented Apr 13, 2021 at 8:30

2 Answers 2

12

DMAR firmware bug. Broken BIOS?

Yes, it is the BIOS that is giving the kernel information that is incorrect (ie. does not follow the specification).

DMAR is mainly used for GPU passthrough to a Windows virtual machine. If you do not use this you can ignore this bug otherwise you will need to look for a BIOS update.

Use 'intremap=no_x2apic_optout' to override the BIOS setting.

Use that and the bug is ignored and no longer shown. Change GRUB_CMDLINE_LINUX_DEFAULT:

sudo vi /etc/default/grub
  • add intremap=no_x2apic_optout nox2apic.
  • Add acpi=off if the system starts complaining about ACPI.

After editting do

sudo update-grub

and reboot.

3
  • 1
    Thanks for the answer. You say DMAR is mainly used for GPU passthrough to a Windows virtual machine but I suspect it can cause problems elsewhere because I'm having some other issues on gnome like freezing desktop, sidebar and top bar. I think it may be realted to this GPU passthrough error. Commented Apr 14, 2021 at 9:19
  • 2
    Unlikely. It is a bug that has been around since 2010 or so and has been deemed benign. But it could very well be that ACPI is the issue and not DMAR. ACPI is used for hibernation and suspend. It will kill your desktop if there is an issue with that. This is the paper on it: software.intel.com/content/dam/develop/external/us/en/documents/… :) See if acpi=off helps.
    – Rinzwind
    Commented Apr 14, 2021 at 9:27
  • 1
    I don't want to sacrifice power management functions for this benign problem. Do I lose energy efficiency if I disable ACPI? Commented Apr 14, 2021 at 12:21
1

I saw the same error after the Linux update, Ubuntu 20.04.3 LTS. I'm also using Dell (7559).

First, I restarted my computer and ran it in recovery mode. While checking logs I noticed that there is a problem with /dev/sda2 and I have to run

 fsck /dev/sda2

So, I ran it, answered 'Yes' on all questions, and restarted the computer. This solved the issue.

A better description and more solutions could be found here fsck error on boot: /dev/sda6: UNEXPECTED INCONSISTENCY; RUN fsck MANUALLY

1
  • I get below error message when I try to run this command: fsck.ext4: Permission denied while trying to open /dev/sda2 You must have r/w access to the filesystem or be root Commented Jun 2, 2023 at 5:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .