0

i'm trying to install the HP MFP M277 printer on Ubuntu 20.04.2 LTS, but i cannot find the correct PPD file.

I've upgraded HPLIP to the version 3.21.2, but nothing changed.

Do you know how i can solve this problem? There's a place where i can download the correct ppd file?

Thanks.

9
  • 1
    Did you try sudo apt-get install hplip-gui hp-plugin then run hp-setup in terminal? – 24601 Apr 10 at 12:13
  • Have a look here: ls -al /usr/share/ppd/HP/*m277* for a .ppd.gz compressed file. Also if I click on the Select from Database... option for drivers in the driver database I can see HP Color LaserJet Pro MFP M277 Postscript (recommended) (listed 14 times for some reason...) The driver database does not seem to have any search/filter options so is a nightmare to find anything as its all just alphabetical on name. – codlord Apr 10 at 12:36
  • Read wiki.debian.org/CUPSQuickPrintQueues. Simplicity. You do not need HPLIP. – brian_p Apr 10 at 19:23
  • 3
  • @brian Ubuntu may be Debian based but do you know for certain that your reference works. There is no mention of Ubuntu in the reference you provided. – 24601 Apr 10 at 20:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.