1

Whet I do:

apt-get install -y libpng-dev libsigc++-2.0-dev libxml++2.6-2v5 libgslcblas0 openssh-client gettext-base rsync slurm-client

41 newly installed packages, among them libhdf5-100. Why is that? I dont see this package on dependency lists of any of packages I install by the command pasted above.

3
  • 1
    Why did you use -y if you didn't expect the results? Why didn't you specify --no-install-recommends if that's what you're after... but really you shouldn't be using -y if you're not fully aware of the consequences of the command; a careless newbie mistake.
    – guiverc
    Apr 10 '21 at 10:51
  • A simple query on your bionic terminal would have provided that answer... why didn't you perform the rdepends query yourself ?
    – guiverc
    Apr 10 '21 at 10:56
  • @guiverc, Thanks! It turned out that HDF is required by Slurm, which is very surprising for me.
    – Aleksander
    Apr 10 '21 at 12:00
1

https://packages.ubuntu.com/bionic/slurm-client

shows it as a requirement.

Why did you use -y if you didn't expect the results?

1
  • Thanks! I was so sure that it has nothing to do with Slurm that I omitted checking this one.
    – Aleksander
    Apr 10 '21 at 12:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.