0

Hello I have to update my NVIDIA driver, but I think I have to put last kernel (5.11). I made all update system via the GUI, but my kernel remains the 5.8

  • Why the software update doesn't make it?
  • Is it ok to install it myself via the terminal?

THanks

edit : enter image description here enter image description here

4
  • What NVIDIA card do you have?
    – Terrance
    Apr 9, 2021 at 17:20
  • geforce rtx 3070
    – SHURA
    Apr 9, 2021 at 17:29
  • The 460 driver that is in the Ubuntu repositories should be able to support that card without going to an Unsupported kernel version.
    – Terrance
    Apr 9, 2021 at 17:33
  • i have the 460.39 installed. It seems i need to upgrade for davinci, right now it doesn't work, i have also lot of issue in blender.
    – SHURA
    Apr 9, 2021 at 17:35

1 Answer 1

0

The version of the drivers should always match the version of the kernel. If you, for any reason, need v5.11 of the driver, you should install v5.11 of the kernel.

In addition, the numbers you are quoting look very strange. Please post the output of

$ uname -a
$ dpkg -l | grep ii | grep \ linux-
$ dpkg -l | grep rc | grep \ linux-

and the list of repos you have

$ grep ^ /etc/apt/sources.list /etc/apt/sources.list.d/*

-Why the software update doesn't make it?

Perhaps you didn't do

$ sudo apt-get update

Please post the exact command you used when trying the update.

-Is it ok to install it myself via the terminal?

What do you mean by this?
Using apt (this is ok), or installing from .deb (not recommended, but if you need it...)?
I never tried it with the type of installation you mean to do, but if you want to install from .deb I guess gdebi is also preferred instead of dpkg.

8
  • ok thanks but why the system update doesn't install the last one?
    – SHURA
    Apr 9, 2021 at 17:12
  • @SHURA - Please see updated answer and post your output. Most likely they are not yet in the repos you have configured. Let me check and post back. Apr 9, 2021 at 17:13
  • sorry i misspelled, i have kernel 5.8.0-4 . I have updated the system via the software not terminal. So my wondering is : if the update software doesnt install the last kernel, is it for a reason or it's a bug? I just want to be sure before updating via the terminal..
    – SHURA
    Apr 9, 2021 at 17:24
  • @SHURA - Please post exactly what is asked... an explanation without verbatim information may be misleading. Apr 9, 2021 at 17:28
  • i edited my question, your grep rc command returns nothing.
    – SHURA
    Apr 9, 2021 at 17:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.