0

After resizing an NTFS partition on an external GPT drive using Gparted the volume doesn't seem to automount on Ubuntu anymore (or other distributions, like OSMC). It has worked fine previously. It still seems to work fine in macOS and Windows 10 where I've been able to browse it just fine and use it as a backup target.

  • Gnome's Disks calls the partition "Partition 2 - 419 GB Unknown". Apparently it can't read the partition name nor the volume label, because neither is named "Partition 2". It also can't seem to determine the partition type, which is listed as Unknown.
  • Another NTFS partition on the same drive is being automounted correctly. Its label and type are being identified properly in Disks. Those are the only two partitions in the GPT.
  • gdisk reports that both these partitions' types are 0700 - Microsoft basic data. I don't know what more Gnome Disks needs apart from that.
  • I used gdisk to remove the customary time bomb (a.k.a. hybrid MBR) that Gparted always so thoughtfully puts on any protective MBR drive it touches. After a reboot it turned out to have no effect, which is reasonable since Disks never used the MBR anyway.
  • I could mount and browse files using mount -t ntfs -o nls=utf8,umask=0222 /dev/sdc2 ./mount-point. As part of the operation it mentioned an unclean file system, and that it was "Fixing..." Apparently it worked, since the volume was accessible afterwards, but it still will not automount after a reboot.
  • chkdsk /f in Windows 10 reports no errors.

I'm unsure why only Ubuntu (and other linux based OSes) can't seem to identify the partition type and automount the volume anymore. Is there an easy way to check?

Did I forget something?

1 Answer 1

-1

It seems that, once again, Gparted managed to ruin a perfectly usable partition table by, presumably, extending the partition to overlap the secondary GPT at the end of the disk.

To summarize, after resizing a partition in Gparted in 2021 you need to:

  • Manually remove the hybrid MBR that you didn't ask for and replace it with a protective MBR (to prevent future disaster)
  • ...and, if you extended the last partition on the drive, shrink the last partition of the drive in order to manually account for the GPT standard. 1 MB will do.

Thank you to this answer, and to the armhf version of gdisk version 1.0.3 that was sort of correct by pointing out that “Warning! Secondary partition overlaps the last partition by [an unreasonably large number of] blocks”, while peculiarly the newer version 1.0.5 on Ubuntu 64 bit did not produce this warning.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.