3

Is there a way to make Linux shares appear in Networks (Win10-Home and Prof) other than using SMBv1 ?

I am running 20.04 with Samba 4.11.6 and I am unable to reach my Linux shares from Windows 10 via Networks when using SMBv2 or 3. I can reach my shares via mapping \name\share or when SMBv1 is enabled on Windows with no issues.

I do not want to use SMBv1 or use the \name\share method.

I unchecked all SMBv1 boxes in Windows and tried various below combinations in my smb.conf file but SMB2 or 3 doesnt work.

client min protocol = SMB2

client max protocol = SMB3

min protocol = SMB2

max protocol = SMB3

protocol = SMB2

protocol = SMB3

server min protocol = SMB2

server max protocol = SMB3

I also shut down all firewalls (Win/Linux) for troubleshooting and tried different registry hacks but so far the only way to make it work is to use the insecure SMBv1. Is there anything that I need to enable on either Win or Linux ?

1
  • Just noting that I have the SMBv1 enabled on my Windows 10 for only seeing the network. When I connect to my Samba shares it connects at SMB 3.11 by default. You can always check your connections on your Samba server by running sudo smbstatus. – Terrance Apr 6 at 22:37
5

There is no way to have Win10 "discover" shares by NetBIOS name because that requires SMB1.

You can connect to the server with a \linux-host-name.local if you want.

Or you could configure WS-Discovery on the Linux server:

I submitted this as a bug / feature request in launchpad: https://bugs.launchpad.net/ubuntu/+source/samba/+bug/1831441

There exists in github something that has most of this already created. One can use it in Ubuntu but it requires some work to implement:

[1] Download the file:

wget https://github.com/christgau/wsdd/archive/master.zip

[2] UnZip it:

unzip master.zip

[3] Rename the python script

sudo mv wsdd-master/src/wsdd.py wsdd-master/src/wsdd

[4] Copy it to /usr/bin

sudo cp wsdd-master/src/wsdd /usr/bin

[5] A systemd service file is already provided in the package it just needs to be copied to the correct location:

sudo cp wsdd-master/etc/systemd/wsdd.service /etc/systemd/system

[6] The wsdd.service file ( /etc/systemd/system/wsdd.service ) has to be edited to remove references to the nobody user:

#User=nobody
#Group=nobody

[7] Then enable the service:

sudo systemctl daemon-reload
sudo systemctl start wsdd
sudo systemctl enable wsdd

Now Win10 can discover the Ubuntu server with its own native WSD protocol and there is no need to enable smb1.

1
  • Thanks for the info. I will be taking the wsdd route. I tested it and it works fine. Thanks again. – canyonrunner95 Apr 8 at 18:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.