1

Suddenly I seem to be having problems downloading videos from youtube using youtube-dl. I am running ubuntu 20.04.2

I did seem to upgrade youtube-dl using this suggestion:

pip3 install --upgrade youtube-dl

and when I check for the version using the command

youtube-dl --version

gives 2021.01.16

However when I try to make use of youtube-dl I get the message;

youtube-dl -f mp4 https://www.youtube.com/watch?v=5BXtgq0Nhsc
[youtube] 5BXtgq0Nhsc: Downloading webpage
ERROR: 5BXtgq0Nhsc: YouTube said: Unable to extract video data

I even tried removing youtube-dl and reinstall from the Software launcher with no luck.

(I had a similar problem running youtube-dl in windows but the problem was resolved there when I updated youtube-dl)

1
  • You should post your comment as an answer, for two reasons: (1) This is the actual solution to your issue, and (2) If you experienced this issue, it will surely also be experienced by someone else. So, posting your answer and marking it as the accepted answer will help someone else, possibly another newbie. In addition, marking an answer that didn't actually resolve your issue as the accepted answer isn't helpful and will cause confusion for others. Sep 19 at 5:51
1

Update it to the latest version with

sudo youtube-dl --update

and then try again.

Edit: Since you wrote you installed it with a package manager and thus you can't update it so easily, for this particular software I'd recommend to install it from its upstream site https://youtube-dl.org/ to your /usr/local/bin directory and use it from there; then you can update it whenever needed (which is often because YouTube often changes some stuff to thwart software like youtube-dl).

You can either have a version from an official repo which is always slightly outdated, or a working one. As a general rule of thumb, you need to update it whenever you want to use it.

I just updated it, and it gives me

sh@balrog:~$ youtube-dl --version
2021.04.01
2
  • Because I installed youtube-dl with a package manager, this doesn't work
    – jim
    Apr 5 at 21:08
  • This should not be marked as the accepted answer as it didn't actually fix the OP's issue. Sep 19 at 5:55
1

The problem seems to have been resolved by updating via pip3 command. It seems I needed a restart ... sorry, I'm a newbie and this is a newbie mistake: "have you tried turning it on and off". I'm happy to leave the question here for other newbie's, but otherwise don't mind if removed..

0

Here's what worked for me. I'm not a fan of the "snap store" but it successfully installed the latest version (2021.06.06) on my xubuntu 20.04.2 Cheers!

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.