0

I would like to ask about issue with Canon I-Sensys printer installation on Ubuntu 20.04 (but I think, the simmilar issue is often, because I found a few threads about it also here in askubuntu).

After successfully installation of Canon ISensys 7200 CAPT driver, version 2.71 from here: https://www.canon.sk/support/consumer_products/products/printers/laser/i-sensys_lbp7200cdn.html?type=drivers&language=en&os=linux%20(64-bit)

(installation was success without any problems), I found the right driver in the list and I added a new printer:

Step1

enter image description here

Step2

enter image description here

Step3

enter image description here

Step4

enter image description here

Everything was done without any problems. But, when I want to print text from editor or printer test page, still I have same error:

Unable to write print data: Broken pipe

enter image description here

I found a few threads about, for example like following, I tried to reinstall xserver-xorg in ubuntu safe mode, but it doesnt help me:

Cannot write bytes: Broken pipe

Also I was calling to the Canon support, but there is nobody to support linux :-(

Thanks a lot for each help.

1 Answer 1

0

Broken pipe is from CUPS. Step 2 indicates you are using the URI socket://192.168.7.11:9100. This is OK, as a socket URI is generally very reliable. Do a quick check of the connection with telnet 192.168.7.11 9100.

In addition to a URI a PPD is needed. lpinfo -m | grep -i 7200C should allow you to find one. What I would then do is set up a print queue with sudo lpadmon -p 7200c -v "URI" -E -m "PPD", substituting for URI and PPD of course.

Test with lp -d 7200c /etc/nsswitch.conf.

Another URI (probably dnssd://...) should be obtainable from lpinfo -v. It coul be tried in place of socket://... .

11
  • Hi @brian_p, thanks a lot, for the help. telnet is working and Im able to connect to the printer
    – klaucode
    Apr 5, 2021 at 17:55
  • result of lpinfo -m | grep -i 7200C is: CNCUPSLBP7200CCAPTJ.ppd Canon LBP7200C CAPT (JP) lsb/usr/CNCUPSLBP7200CCAPTJ.ppd Canon LBP7200C CAPT (JP) CNCUPSLBP7200CCAPTK.ppd Canon LBP7200C CAPT (UK) lsb/usr/CNCUPSLBP7200CCAPTK.ppd Canon LBP7200C CAPT (UK) CNCUPSLBP7200CCAPTS.ppd Canon LBP7200C CAPT (US) lsb/usr/CNCUPSLBP7200CCAPTS.ppd Canon LBP7200C CAPT (US)
    – klaucode
    Apr 5, 2021 at 17:56
  • sudo lpadmon -p 7200c -v "URI" -E -m "PPD": If I understand correctly, I put to the concole this: sudo lpadmin -p 7200c -v "socket://192.168.1.11:9100" -E -m "lsb/usr/CNCUPSLBP7200CCAPTS.ppd" and result is: lpadmin: Printer drivers are deprecated and will stop working in a future version of CUPS.
    – klaucode
    Apr 5, 2021 at 17:58
  • lp -d 7200c /etc/nsswitch.conf - result is: request id is 7200c-57 (1 file(s)) Thanks a lot for your help :-)
    – klaucode
    Apr 5, 2021 at 17:59
  • @acqsk Everything you have done looks fine. But did you get ink put on paper?
    – brian_p
    Apr 5, 2021 at 18:27

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .