I've been using ndiswrapper to make work some wireless cards using its Windows drivers, because they are not yet supported by free Linux drivers. Until Ubuntu 12.04.

Now, I can install Windows Wireless Network Drivers (ndisgtk) from Ubuntu Software Center but when I try to load the driver, I get an error message saying

FATAL: Module ndiswrapper not found.

I get the same error if I type on a terminal sudo modprobe ndiswrapper.

How can I workaround this bug until it's fixed?

  • I'm curious - what wireless card is not being recognised by the new linux kernel? NDISWrapper should be the last resort for wireless issues. – fossfreedom May 8 '12 at 15:21
  • @fossfreedom For me, it's not a wireless card, but rather a USB Wireless device (Netgear N300 WNA3100). – Ryan McClure May 8 '12 at 18:21

This bug is reported here. I managed to workaround it so I thought I could share the fix so others can benefit and perhaps contribute more accurate information. Information source is soneedu commnent and Ubuntu Wiki.

Update: There is another fix suggestion which seems way more easy to do, and it was confirmed in the comments that it works.

Fix suggestion #1:

  1. Install the package ndiswrapper-dkms
  2. Run the command: sudo modprobe ndiswrapper

Now you should be able to use the Windows Wireless Network Drivers (ndisgtk) utility.

Don't forget to make sure that ndiswrapper is being loaded on system startup.

Fix suggestion #2:

Tested on Ubuntu 12.04 32 bit.

Go to Ubuntu Software Center, search for ndisgtk and open its entry. Install it in case you haven't yet. Check the add-on Source for the ndiswrapper Linux kernel module (ndiswrapper-source) and click "Apply Changes".

Now there must be a file called ndiswrapper.tar.bz2 in /usr/src. Open a terminal and go to the directory:

cd /usr/src

Extract the file:

sudo tar -xjf ndiswrapper.tar.bz2

Go the the extracted directory:

cd /usr/src/modules/ndiswrapper

Compile and install:

sudo make
sudo make install

Add the module to the system:

sudo modprobe ndiswrapper

Open the file:

gksudo gedit /etc/modprobe.d/ndiswrapper.conf

Delete the content of the file, save and close. Then let the module write the configuration file again:

sudo ndiswrapper -m


Now you should be able to use the Windows Wireless Network Drivers (ndisgtk) utility.

Don't forget to make sure that ndiswrapper is being loaded on system startup.

  • re: the updated, easier fix suggestion: As with those in the bug thread, I can confirm that, after researching and hairpulling for about 18 hours (!) going to Synaptic Package Manager and installing ndiswrapper-dkms then entering sudo modprobe ndiswrapper in a terminal, me and my Netgear WG121 are once again on the air. Thanks for the link! – user66412 May 27 '12 at 4:09
  • Thanks for confirming the fix. I updated my answer to include the 'modprobe' command. – Tom May 27 '12 at 16:21
  • Hi, for information, this is not working under 12.10, as there is a problem with version 1.57 of the sources. See askubuntu.com/questions/213360/… for 12.10 correction. – Joël Mar 17 '13 at 16:40

This same problem just started happening for me a couple days ago and in my search to fix it, I found a post this morning on ubuntuforums.org with an alternative fix. Since I haven't seen any mention of this method yet here, I figured i go ahead and post it for everyone else.

Here's HalfNote5's original post:

Since I lack enough reputation to post the screenshot here, I've went ahead and copied the text instead.

12.04 and ndiswrapper modprode "FATAL: Module ndiswrapper not found"

Just a heads up for people with ndiswrapper problems (I crawled the Ubuntu forum and didn't really find this; the info was aggregated from several other sites.)

If you're using an older version of ndiswrapper, and you have the gui AND the program interface (and ndiswrapper even shows that the hardware is attached) but when you modprobe, you're getting this:

FATAL: Module ndiswrapper not found

It means you need to install


(And of course, install ndiswrapper-utils-1.9)

None of which appear to be "Dependencies" for ndiswrapper, but without which it simply does not work.

Apologies if this is already posted somewhere, but when I was looking for it, I saw several people asking, but no definitive answers.


P.S. My install was Xubuntu Alternate. Your experience may vary. ; )

Last edited by HalfNote5; May 26th, 2012 at 09:13 AM.. Reason: slight correction

Link to HalfNote5's Original Post

Since I use Ubuntu 12.04 LTS as my OS, I just searched each installs name in the Ubuntu Software Center program and installed each one.

After everything finished installing, I reopened ndiswrapper, then removed and reinstalled the wireless driver.

Ever since then, my wireless adapter has working perfectly.

I hope my answer helps make this fix easier, even if just a little, for others with this same problem in the future.


Thanks to whoever posted it. It took me almost a day to get my WiFi working in my old laptop with broadcom PCI wlan. I used ndiswrapper by directly downloading it but it didn't work for me. I tried to install it by compiling the soruce code but I got into a compilation error where it said error: ‘struct kernel_stat’ has no member named ‘cpustat.

Then I searched and I found that I have to install ndiswrapper-1.58 source. I dowloaded the source and followed the following instructions after unpacking the archive and changing to the source directory.

sudo make
sudo make install
sudo modprobe ndiswrapper
gksudo gedit /etc/modprobe.d/ndiswrapper.conf
<< delete all the entries here. it will re create it>>
sudo ndiswrapper -m
lsmod | grep ndiswrapper
<<it should list your module>>
gksu gedit /etc/modules
<< add *ndiswrapper* to the end of this file>>
sudo reboot

Now your WiFi should be up and running.

  • AAaah at last! Thank you for bringing us the fact that a newer version is available... I was struggling with this error, without any hint where the error could come from. For info, I'm under Xubuntu 12.10. – Joël Mar 17 '13 at 15:52

After trying a few suggestions found here and getting nowhere I fixed the dreaded:

"FATAL: Module ndiswrapper not found"

error message by adding Glenn Washburn's PPA to my software sources. It's fairly easy to do compared to other methods and it's the only thing that worked for me. Just type the following in the terminal:

sudo add-apt-repository ppa:crass/ndiswrapper

You'll be prompted for your password of course Then asked to confirm adding this by pressing enter. Then just update your software and it works. Pretty simple. I must mention that when you visit this PPA you'll see this note:

You can update your system with unsupported packages from this untrusted PPA by adding ppa:crass/ndiswrapper to your system's Software Sources.

I don't know what to make of that but here I am online because of it.


I found a fix do this and it will work

  1. exit out ndis if you dont have it search it in the package installer
  2. ndis moduel install both those from package installer
  3. open it and check if it worked!

In Ubuntu 14.04 I needed to fix loader.c and pe_linker.c files in ndiswrapper source code:

#include <linux/vmalloc.h>


sudo apt-get purge libc6-dev
sudo apt-get install libc6-dev    
sudo apt-get install build-essential

Then, I followed the next steps of suggestion #2

  • 2
    If you want to improve another answer, please suggest an edit to it and don’t create a new (incomplete) answer. – David Foerster Nov 7 '16 at 20:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.