3

I have a problem when launching Brave and Opera Browsers. The first time I try to use after getting on my computer, it took them too long to start running. However, Firefox and Chrome haven't got the same problem.

Lanching Brave by terminal I receive this output:

$ brave -v
Gtk-Message: Failed to load module "appmenu-gtk-module"
Gtk-Message: Failed to load module "canberra-gtk-module"
Gtk-Message: Failed to load module "canberra-gtk-module"
libGL error: pci id for fd 24: 1002:15d8, driver (null)
libGL error: No driver found
libGL error: failed to load driver: (null)
libGL error: pci id for fd 24: 1002:15d8, driver (null)
Failed to parse JSON adblock resources: EOF while parsing a value at line 1 column 0
pci id for fd 25: 1002:15d8, driver (null)
libGL error: failed to create dri screen
libGL error: failed to load driver: radeonsi
[8489:8489:0402/192105.813457:ERROR:viz_main_impl.cc(150)] Exiting GPU process due to errors during initialization

While in opera I get more or less the same:

$ opera -v
Gtk-Message: 19:22:11.269: Failed to load module "appmenu-gtk-module"

(opera:8929): Gtk-WARNING **: 19:22:11.289: Theme parsing error: gtk.css:1555:23: 'font-feature-settings' is not a valid property name

(opera:8929): Gtk-WARNING **: 19:22:11.296: Theme parsing error: gtk.css:3591:25: 'font-feature-settings' is not a valid property name

(opera:8929): Gtk-WARNING **: 19:22:11.297: Theme parsing error: gtk.css:4053:23: 'font-feature-settings' is not a valid property name
/usr/share/libdrm/amdgpu.ids: No such file or directory
[9026:9026:0402/192211.851284:ERROR:sandbox_linux.cc(374)] InitializeSandbox() called with multiple threads in process gpu-process.
[8929:9031:0402/192214.014451:ERROR:udev_watcher.cc(97)] Failed to begin udev enumeration.
[8929:8929:0402/192214.779946:ERROR:named_platform_channel_posix.cc(145)] connect /home/jorge/snap/opera/118/.config/opera/oauc_pipe_r: Connection refused (111)

But the key problem is that when I try to install the canberra/gtk modules I get...

$ sudo apt-get install libcanberra-gtk-module libcanberra-gtk0
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias       
Leyendo la información de estado... Hecho
libcanberra-gtk-module ya está en su versión más reciente (0.30-7ubuntu1).
libcanberra-gtk0 ya está en su versión más reciente (0.30-7ubuntu1).
Los paquetes indicados a continuación se instalaron de forma automática y ya no son necesarios.
  libfprint-2-tod1 libllvm10
Utilice «sudo apt autoremove» para eliminarlos.
0 actualizados, 0 nuevos se instalarán, 0 para eliminar y 10 no actualizados.

So they say I've already got it.

Very confused about this kind of things! Any help from anyone please??

1
  • For OPERA: disable "battery saver".
    – Rinzwind
    Apr 18, 2021 at 14:05

3 Answers 3

1

I've been struggling with a very similar issue for several weeks now. I solved it today by reinstalling opera directly from a .deb file:

  1. I started by uninstalling snap's Opera with sudo snap remove opera in the terminal.
  2. On the Opera website (https://www.opera.com/download) I downloaded their .deb install file. (currently opera-stable_75.0.3969.171_amd64.deb, but presumably this is updated regularly.)
  3. I installed this via apt in the termianl. I am told it is essential to indicate the full file path for this process (no ~/). Additionally, the 'tab' key was helpful in automatically filling out the specific filename. sudo apt install /home/[USER NAME]/Downloads/opera-stable_75.0.3969.171_amd64.deb
0

install gtk modules sudo apt-get install appmenu-gtk2-module appmenu-gtk3-module if you haven't done this first

maybe you have GPU driver issues, include the output of lspci -vnn | grep "VGA" in your question,

try to uninstall NVidia drivers and install mesa-dri-drivers..

sudo add-apt-repository ppa:kisak/kisak-mesa
sudo apt update
sudo apt install mesa

and see if the problem still exists

0

Have the exact same with brave, had to sudo snap remove brave and follow install instructions from here https://brave.com/linux/#release-channel-installation annoying though.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .